This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by simonw-25 5 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 21, 2019 at 6:03 am #3651719

simonw-25

when i use the english page , the product have not show up..

but if i use the chinese page go to shop page then switch to english it show up..

so how can i fix it

April 22, 2019 at 3:35 pm #3656729

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Please update all outdated plugins and themes, specially WPML plugins, to their latest version.

Note: Don't forget to create a full backup of the site before making any change.

If the issue persists then I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

April 23, 2019 at 10:52 am #3662263

simonw-25

when i try to update the plugin the wpml plugin all show this error

April 23, 2019 at 11:18 am #3662749

simonw-25

and when i add the code into wp-config.php , it show error in line 113 , then my website go 500error

April 23, 2019 at 2:37 pm #3664785

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Please take a closer look at the code and use the single quotes (') instead of their HTML equivalent ('), this is why you are getting the 500 error.

Also, I recommend you to manually update the WPML plugins by following the steps described in this link: hidden link

You can download the latest WPML plugins from this link: https://wpml.org/account/downloads/

Could you tell me if the issue persists after updating the plugins and increasing the memory limit?

Regards,
Carlos

April 25, 2019 at 9:31 am #3680459

simonw-25

hi , the last error is fix thx so much , but something more want to ask , how can i change the Language on the option of language (when chinese the english option also show in chinese , it is unfriendly to user) ,

April 25, 2019 at 9:32 am #3680509

simonw-25

i have already change it in setting but its have not any change in the front end

April 25, 2019 at 4:03 pm #3684387

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I'm glad to hear that the issue is solved 🙂

As the original issue is solved I kindly ask you to open a new ticket and describe this new issue with the language switcher. Please assign this new ticket directly to me so we can continue working toguether.

By opening a new ticket for the new issue we will be following the forum's rule of having one ticket per issue. This will also help future clients to find answers to similar problems and you will get a better support experience.

Thank you very much for your understanding!
Best regards,
Carlos

April 28, 2019 at 9:44 am #3697545

simonw-25

My issue is resolved now. Thank you!