We have released WPML Beta 4.3.4. Before reporting issues please make sure to give it a try - this version resolves all known issues with the major WPML 4.3.0 release

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 33 replies, has 2 voices.

Last updated by alinam-2 6 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 26, 2019 at 3:05 pm #3691893

alinam-2

Additional info
I just changed a product in a category X that was invisible.
Saved the changes (in both the original and the translated version).
And then, the category X becomes invisible and let me see this result:
Fatal error: Maximum execution time of 30 seconds exceeded in /home/polinacoutu/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-post-element.php on line 11

April 29, 2019 at 4:13 am #3699933

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the patience, We will be releasing a bug fix soon, Probably by the end of today. I will update you as soon the fix is available.

Kind regards
Raja

April 29, 2019 at 8:53 am #3701331

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

We have released a new patched version with a fix of your issue. Please update WooCommerce Multilingual to the version 4.6.2.1.

Kind regards
Raja

May 1, 2019 at 6:10 am #3716169

alinam-2

Hi,
I tried, it's better but the database remains wrong: the stock are dis-synchronized between original and translated languages, leading to "out of stock" when stock is not 0.
When adding variations to a product in original language, the translated version switches to out of stock.
Looks like there is a communication problem between WPML and WC.
I tried with 1. desactivating non necessary plugins and 2. storefront theme ... and no impact
Kind regards

May 1, 2019 at 6:22 am #3716223

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,
Please go to WooCommerce > WooCommerce Multilingual > Support/Status, Click on the Troubleshooting link located at the bottom.
In the troubleshooting page select,
- Sync products variations
- Sync product stock quantity and status
Click start. Wait for the process to complete. Check if the issue is resolved.

Kind regards
Raja

May 1, 2019 at 6:25 am #3716227

alinam-2

Sorry, I forgot to mention it, I tried that too. No effect.

May 1, 2019 at 6:45 am #3716267

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the clarifications, It seems like you have limited stock for the products and they seem to have been sold old. Please check and verify with the order quantity for the products.

I have updated SKU for a product to verify the same I have added a dummy SKU for the product hidden link it's now working fine because there are no orders related to SKU.

Please update the Product stock quantity or the SKU either of this would solve your issue.

Please let me know if you still have an issue.

Kind regards
Raja

May 1, 2019 at 7:01 am #3716375

alinam-2

Hi,
Sorry, in the case of your exemple, if I did not misunderstand, the French version is OK (original language), but the English version (translated) says out of stock. See images.
Yes, I work with low stock, it's handmade.
Yes, it's sometimes related to a post order, but it's also true now when I add variations to an existing product -ie switch from single product to variable product.
Last, the problem is only on variable products
Kind regards

May 2, 2019 at 5:45 am #3721921

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have tried a few troubleshooting steps. nothing helped, Please clone your site to our private server for a detailed debugging. details about migration will be sent in my next private reply.

KInd Regards
Raja

May 2, 2019 at 5:48 am
May 2, 2019 at 6:50 am #3722147

alinam-2

Hello,
The migration is completed.
Thank you for your time
Kind regards

May 2, 2019 at 12:49 pm #3724633

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for your patience, I am able to reproduce the issue in a clean installation I have requested the second tier of supporters for a detailed look into the issue. I will let you soon once I have an update form them.

Kind regards
Raja

May 7, 2019 at 12:58 pm #3758051

alinam-2

Hi
Any news? We started almost 2 weeks ago, and it still does not work
Kind regards

May 8, 2019 at 5:13 am #3763855

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Kindly apologize at this moment we don't have any fix, The issue is still in the escalated queue I have requested the developer to have a look into the issue, requested to provide at least a workaround which would help at this moment. I will keep you posted with the happenings.

Kind regards
Raja

May 9, 2019 at 4:31 am #3773053

alinam-2

Hi,
It's now 2 weeks that Woocommerce multilingual don't work.
When I read the feedbacks on wordpress.org, it says that it's bugging at every update, support is slow, etc.
What do you recommend?