This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
September 27, 2018 at 1:45 pm

Claudio

Hi, I'm having an issue with shortcodes rendering w/WPML together with Toolset - after updating them, some Custom Post Types completely stopped rendering all shortcodes in them, even the default [gallery] shortcode.

For example:

hidden link (en, not working)
hidden link (it, translated, fully working)

Weird enough, this just happens in only a few pages, but it's a replicable issue; I can restore an old backup, update just WPML+Toolset and get the same issue each time.

The issue appeared first after I had to update the following plugins due to changes to the Google Maps Auth API:

Toolset Types, Version 3.1.1
Toolset Maps, Version to 1.5.3

and in turn,

WPML Multilingual CMS, Version 4.0.7 (update required by Toolset)
WPML CMS Nav Version, Version 1.4.23 (update required by WPML)
WPML String Translation, Version 2.8.7 (update required by WPML)
WPML Translation Management, Version 2.6.7 (update required by WPML)

September 28, 2018 at 2:09 pm #2774161

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @claudio, welcome to the WPML support Forum!

- Does this occur only in translations, or also in the original language?
- If you create a new page, does the same issue happen?

Please try the following:
- Go to the edit screen of the page with the issue (default language)
- Do a small modification on the page content and save
- Go to the edit screen fo the translation
- Do a small modification and save

I also checked the settings of your server through debug log and saw that some items need attention:
Increase WP memory
If possible, please increase the PHP memory limit to 256mb. Currently this memory is set to 128mb.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Please let me know if it worked for you.

All the best,
Diego