This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Yvette 4 months ago.

Assigned support staff: Yvette.

Author Posts
June 6, 2019 at 1:47 am #3964677

nielsC-4

Tell us what you are trying to do?
Allow user to see only language options for which translation are available

Is there any documentation that you are following?
Yes, I had created ticket fora me earlier and supporter from WMPL suggested following steps

Just use the 'skip language' option in WPML > Languages > Language switcher options : hidden link

Is there a similar example that we can see?
yes

What is the link to your site?
hidden link

June 6, 2019 at 1:35 pm #3969539

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

This is the correct configuration for the behvaiour that you want.

Could you please try the following diagnostic steps.
1. Activate the footer language switcher in WPML > Languages
Are the list of languages proposed still the same?

2.Clarifications
Does this only happen on this particular page?

Thanks

June 7, 2019 at 7:21 am #3974415

nielsC-4

Could you please try the following diagnostic steps.
1. Activate the footer language switcher in WPML > Languages
Are the list of languages proposed still the same?

- Yes, the languages proposed still the same

2.Clarifications
Does this only happen on this particular page?
- Issues is faced on all pages of wordpress

June 7, 2019 at 8:48 am #3974905

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

June 7, 2019 at 8:57 am #3974941

nielsC-4

Hi Let me know where should I share wordpress credential details.

June 9, 2019 at 8:00 pm #3983673

nielsC-4

Hi where should i share credentials?

June 10, 2019 at 7:05 am #3985471

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hmmm you should see a "private area" open just above the comments section.

June 10, 2019 at 2:06 pm #3987885

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

It appears that the header switcher showing more languages than it should is not our standard WPML language switcher. The standard language switcher on this page on the footer, correctly only displays the translated languages of the page. (see images)

Can you tell me more about the language switcher in the header? The CSS classes indicate it is a custom switcher.

June 12, 2019 at 7:28 am #4001111

nielsC-4

Hi,
Thanks let me check and get back to you.

June 12, 2019 at 8:44 am #4002041

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK - this will remain open in your inbox. Please reply when you are ready.

June 14, 2019 at 6:00 am #4018617

nielsC-4

Hi, I tried removing custom css still issues is not getting fixed.

June 14, 2019 at 6:44 am #4018733

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

It won´t be enough to remove the CSS,

Can you find where the language switcher is added to your theme in the header? PHP code, widget definition, theme configuration ...???

I believe that the switcher code itself is not from WPML but from somewhere else.

My suggestion is that you replace the language switcher code with a call to the official WPML switcher as described here:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#custom-locations

The topic ‘[Closed] Show only language which translations are available’ is closed to new replies.