This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by sabrinaB-7 2 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 14, 2019 at 1:10 pm #4205635

sabrinaB-7

Tell us what you are trying to do?Hi, I have problems getting the settings correct. My theme shows a "taxonomy status" in the featured image. All taxonomies are translated in all languages supported by the site.
I "think" I have set my wpml settings to show the default language in all languages when the content is not translated . However the taxonomies in my opinion on the featured image should display in the correct language (as the translations are added) when selecting a certain language but they don´t.
For example: We select the english language, and the "status" states "For sale"
NOw, We select the spanish language and the status should say "se vende" but it states "for sale" instead.
The title etc displays on the spanish site also in english which I understand because I havent translated it, but the taxonomies surely are possible to automatically show in the correct language?!

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

July 15, 2019 at 7:53 am #4208061

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Taxonomies need to be translated individually by you. WPML doesn't automatically translate taxonomies.

In the link below there is some helpful documentation regarding translating custom taxonomies:
https://wpml.org/documentation/getting-started-guide/translating-post-categories-and-custom-taxonomies/

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response. 🙂

Kind regards,
Mihai Apetrei

July 16, 2019 at 1:10 pm #4220273

sabrinaB-7

Hello, Yes, I know, maybe I explained myself wrong.

I personally have translated all taxonomies individually in every single language. Yet they show in english when other languages are selected.
Help would be appreciated thanks.

July 16, 2019 at 3:28 pm #4221791

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you so much for explaining to me the situation.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 17, 2019 at 3:49 pm #4231981

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they work.

I will spend more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai

July 19, 2019 at 12:15 pm #4246329

sabrinaB-7

HI,
thank you for your message. You say they work. Did you mean to say that you can confirm that they DO NOT work?
Regards
Sabrina

July 19, 2019 at 10:18 pm #4248457

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Sabrina! 🙂

I was referring that the credentials worked and I was able to log into the site.

The investigation will take me a bit more and I will get back to you on Monday as I don't work on the weekends.

I will keep you updated!

I'm leaving this ticket assigned to myself.

Kind regards,
Mihai

July 22, 2019 at 2:18 pm #4258447

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Sabrina.

It is very weird that some of them are showing with "Se vende" while some of them are showing "for sale".

Can you please:

1. Create a full backup of the site

2. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

3. Go to WPML > Support > Troubleshooting

Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix terms count"
• "Fix post type assignment for translations"

4. If the issue is still happening, can you please try this:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and if you were able to find anything.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 23, 2019 at 1:23 pm #4266447

sabrinaB-7

Hi, thank you, I have edited the wp config file and now in wpml-support it states 256mb.
I also updated the php verison. I have tried everything up to step 4 . But still the problem remains.
I will try your last sugesstions by deactivating the plugins, but I will need some more time, so please leave this ticket open until I had the chance to do so over these days.
Thank you.