Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Otto 4 years ago.

Assigned support staff: Otto.

Author Posts
November 23, 2017 at 3:49 pm

francoisP-2

Hi,

Using WPML and WooCommerce I have a problem showing images in the other language.

Main language is French and other is English.

French products are here: hidden link

In Media translation the following options were checked and the items were processed successfully:
- Translate existing media in all languages
- Duplicate existing media for translated content
- Duplicate the featured images for translated content

But the images for products in English are still not showing, see here: hidden link

What am I missing?

Thanks!

Regards,

François

November 25, 2017 at 12:21 pm #1441177

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello François,

Thank you for contacting the WPML support!

I went to WPML > Media Translation and in the second block marked all the options too.

Then I went to edit this product:
Moulinet rond sans rotation avec crochet et courroie de vinyle (34 po.)

just updated the original and now the images show on the front end:
hidden link

Can you please try it with another product?

❌ Before proceeding please make a full website backup! ❌

If it works, I suggest you bulk update all the products (or in batches) following these steps:
-Go to Products
-Select a bunch (you may modify the Screen Options for bigger batches)
-From the Bulk Actions drop-down select Edit
-Without changing anything "update"

Let me know your results, please.

Kind Regards,

Otto

November 27, 2017 at 2:11 pm #1442434

francoisP-2

Hi Otto,

Followed the procedure but pictures still not showing.

This is a test site so we can do what we want.

I need to find the right procedure before applying it to the production site.

Can you check if it works for you?

Thanks!

Regards,

Francois

November 27, 2017 at 3:50 pm #1442556

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Francois,

If you try it with just a single product does it work? Are the images showing?

You may need to update the translations also.

You can do it in bulk too:
after updating a bunch of original products, switch to the secondary language using the switcher in the admin bar and do the same for the translations

Let me know if this helps, please.

Kind Regards,

Otto

The topic ‘[Closed] Showing images in other language’ is closed to new replies.