This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Setting the specific product category to either Dutch or English, does not show the same items on both languages pages.

Solution:

Increasing the PHP memory limit and changing the widgets via the Dashboard > Appearance > Widgets solved this issue.

Relevant Documentation:

https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

This topic contains 3 replies, has 2 voices.

Last updated by Itamar 3 months, 1 week ago.

Assigned support staff: Itamar.

Author Posts
July 16, 2019 at 11:46 am #4219721

erikav-3

Hi there!

I would like to show products via the product category on a page, translated to two languages: Dutch and English.

Setting the specific product category to either Dutch or English, does not show the same items on both languages pages.
For example:
Dutch: hidden link
English: hidden link

As you will see, I entered several product list widgets to display the spring/summer items on the Dutch page:
1. should be visible on the specific languages page only
2. should be visible on Dutch only
3. should be visible on English only

On the English page, I used option 1 only. This results in showing all items, not just the spring/summer collection.

The product categories have been translated from Dutch to English.
However, these categories do not pop up at:
- the widget
- neither at productcategory selection while adding the product to the site.

Could you help me out to sort this issue? As I am kind of 'lost'?

Thanks for your reply!

Kind regards, Erika

By the way: this is a testing website, a duplication of the original website.

July 16, 2019 at 1:43 pm #4220635

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can't see the issue on your site because you have enabled maintenance mode.

The options for widgets display with WPML are the following.
1. All Languages.
2. Any specific language on the site.
Please see the attached screenshot.

You wrote:
As you will see, I entered several product list widgets to display the spring/summer items on the Dutch page:
1. should be visible on the specific languages page only
2. should be visible on Dutch only
3. should be visible on English only

So I'm not sure what setting did you change. Mainly I do not understand option one 'should be visible on the specific languages page only'.
Can you please elaborate on this point?

Also, please correct the following. By looking at the debug info that you have attached I can
see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above.
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform that procedure and see if it help?

Thanks,
Itamar.

July 16, 2019 at 7:13 pm #4223437

erikav-3

Hi Itamar,

Increasing the PHP memory limit and changing the widgets via the Dashboard > Appearance > Widgets solved this issue. Previously I changed the widgets via the Customizer panel, which did not seem to work. My issue is resolved now. Thank you!

Kind regards, Erika

July 17, 2019 at 7:04 am #4226249

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great, I'm glad that it is solved now!
Good luck with your web projects 🙂
Itamar.