This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Andreas W. 1 month ago.

Assigned support staff: Andreas W..

Author Posts
August 29, 2019 at 9:51 pm #4483617

alexanderV-19

On the German version the sidebar on the my account page is not showing for some reason.
When I delete the German version and create a new one using the Duplicate function it appears. As soon as I change the title, it disappears again.

Same like here: https://wpml.org/forums/topic/side-menu-in-my-account-page-orders-addresses-not-appear-in-translations/

August 29, 2019 at 10:45 pm #4483735

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Sadly, I do currently not have access to the latest version of the Flatsome Theme.

Could you please install the Flatsome Theme Version 3.8.3 on the following test site and let me know if you experience the same issue:

One Click Login: hidden link

I also realized that there are currenlty erros displaying on your site. In case the issue will not appears on the test install using the Flatsome Theme then please run the wp-debug on your site or provide me access to your server.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards,
Andreas

September 1, 2019 at 5:11 pm #4492907

alexanderV-19

Hey,

I just installed the flatsome theme.

Can you work with it?

Best,
Alex

September 2, 2019 at 3:21 pm #4498207

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I did not experience a similar issue on the test-site which might be realted to teh UX Builder. Forsome reason the builder is not active on the test site. I disabled Gutenberg and looked for an option to activate the Flatsome UX Page Builder. Could you please assist me here?

Further, did you try to run the wp-debug on your live site, as mentioned in my last message?

Kind regards
Andreas

September 2, 2019 at 3:49 pm #4498443

alexanderV-19

Hi,

I just set up the flatsome theme.

It is now showing the sidebar anymore.

Best regards,

Alex

September 2, 2019 at 3:50 pm #4498495

alexanderV-19

I added the debug code to the wp config. However, there is no debug file in the wp content folder...

September 2, 2019 at 4:02 pm #4498751

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you very much for your assistance.

I can see you imported demo content. Could you please quick provide me short list with the steps you took in order to escalate the issue to our compatiblity team?

Did you do nothing more than activating the theme and enabling UX Builder, besides importing the demo content?

Kind regards
Andreas

September 2, 2019 at 4:03 pm #4498757

alexanderV-19

correct. I only did the automatic flatsome setup.

September 2, 2019 at 4:13 pm #4499017

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I found a similar issue on our compatiblity tickets which is about 2 years old. We never received a reply from the theme author. In this case the theme author provided a new template to the client in order to fix the issue.

I would advise you to contact the theme author right away and besides I will consult our compatiblity team if there is something else we can do from our side.

Kind regards
Andreas

September 17, 2019 at 10:37 pm #4591219

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing you in order to follow up about the issue with Flatsome.

Did you reach out to the theme authors and received any kind of feedback yet?

Kind regards
Andreas

September 18, 2019 at 2:21 pm #4597535

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As far I can see the account section is now working for your translated page.

May I ask if the issue got solved with the Flatsome 3.9 update?

Kind regards
Andreas