This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.29 hours from now. Thank you for your understanding.

Author Posts
November 2, 2019 at 8:42 pm

sophieZ-2

Hi,

since the update from version 4.6.7 to 4.7.2 the instruction text for bank transfer and the bank data (see screenshot 1) are placed twice in the confirmation mail which is sent to the customer (see screenshot 2):

Screenshot 1: hidden link
Screenshot 2: hidden link

If I deactivate the WooCommerce Multilingual plugin or return back to 4.6.7 the information is placed only once in the mail correctly. (But returning back gives me a warning in the backend that I should update to have WPML work correctly).

Could you help?

Thanks!

Best,
Georg

November 5, 2019 at 8:38 am #4886261

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello Georg,
Thank you for contacting WPML support.

1.- We released a new version of WPML plugins, including WCML plugin too. I would like to ask you to update all WPML plugins and double check if the issue persists with this latest version.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

November 5, 2019 at 3:27 pm #4890911

sophieZ-2

Hi Carlos,

Thanks for your reply. I have updated all plugins and the WP Core to the latest versions and increased the PHP memory to 256MB. The error still occurs though:

Order with active WooCommerce Multilingual:
hidden link

Order with DEACTIVATED WooCommerce Multilingual:
hidden link

Still need help.

Thanks a lot!

Best,
Georg

November 5, 2019 at 3:33 pm #4891023

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Georg,
Thank you very much for your feedback.

Could you describe the step to edit the original text in the confirmation email?

Regards,
Carlos

November 9, 2019 at 2:21 pm #4918307

sophieZ-2

Hi Carlos,

since it's easier to explain via video you you can find my answer here:
hidden link

Thanks!
Best,
Georg

November 9, 2019 at 7:59 pm #4919075

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Georg,
Thank you very much for the screencast 🙂

I'm consulting our specialists about this issue. I will get back to you as soon as I get an answer from them.

Thank you very much for your patience.
Regards,
Carlos

November 12, 2019 at 8:02 am #4929453

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Georg,

Our specialists kindly requested to reproduce this issue in a new test site. I have created a fresh new WordPress install with WPML plugins installed and setup already so you can reproduce the issue. I leaved Woocommerce and Woocommerce Multilingual so you can configured and reproduce the issue.

You can automatically log in the test site by following this link: hidden link

You can see the emails sent in this link: hidden link

Could you tell me if you where able to reproduce the issue?

Regards,
Carlos

November 16, 2019 at 3:50 pm #4958849

sophieZ-2

Hi Carlos,

Unfortunately I am not able to reproduce the error in your test site. I was able to find out that the error occurs only if the Woocommerce Multilingual plugin AND the plugin "
PayPal for WooCommerce" are enabled (which I need for PayPal Express). As soon as one of both plugins are disabled this error doesn't appear anymore. Would you be able to debug this on my site with the login data I provided in my initial post?

Thanks a lot!
Best,
Georg