This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Mihai Apetrei 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 27, 2018 at 4:43 pm #2771284

Jack Vo

Hello,

I posted my blog in English but it shows also in the Thai-lang site.

hidden link (This is my blog in English) .

(It also show in Thai hidden link which is supposed not to show

This is my blog setting (doesn't have any Thai translation). hidden link

Thanks.

---------

In contrast, the Thai article works well and doesn't show in English website.

Please help me.

Thanks

September 28, 2018 at 11:10 am #2773343

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see in the debug info, in your settings this is the selected option for how to translate posts: "Translatable - use translation if available or fallback to default language".

This is the reason why your untranslated (english) post is showing on another language, too, because the post falls back to the default language (english) because it doesn't find any translation available.

To change this, you will need to:

1. Go to your WordPress dashboard
2. Go to WPML > Settings
3. Scroll down until you find the "Post Types Translation" section
4. On the "Posts (post)" line, make sure you check the "Translatable - only show translated items" box
5. After this, scroll down a bit more and click the blue "Save" box

Now untranslated posts should not show up anymore in other languages.

Please let me know if this fixed your issue.