This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 3 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 16, 2019 at 12:29 pm

markusS-68

Dear wpml-team

I just finished translating the site (ocantodogalo.com) to english and french.

After testing out if both of the new languages work, I got following errors:

EN=
Fatal error: Maximum execution time of 30 seconds exceeded in /nhldata02/304/158304/data/web/ocantodogalo2017/htdocs/wp-includes/wp-db.php on line 1350

FR=
Fatal error: Maximum execution time of 30 seconds exceeded in /nhldata02/304/158304/data/web/ocantodogalo2017/htdocs/wp-includes/template.php on line 661

Both sites are broken.

This is a booking website - please help me to make it work again asap, it's very important.

Thanks!

June 17, 2019 at 9:16 am #4033715

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following steps after a full site backup and check the error is existing or not.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Go to WPML>>Support page

3) Click on Troubleshooting link (blue link in the middle of the page)

4) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

June 18, 2019 at 4:36 pm #4045307

markusS-68

Hi Bigul!

Thank you very much for your assistance.

I've tried everything you said - Without any luck, the problem still occurs, just as before...

what else could I do?

Thanks alot!

June 18, 2019 at 6:39 pm #4045913

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please increase the *Max execution time* value(in PHP.ini settings) to 120 and check the issue is existing or not.

If the issue exists, please upgrade your PHP version to 7.2 or 7.3 after a site backup. It will help to improve site performance.

--
Thanks!

Bigul

June 24, 2019 at 5:30 pm #4079003

markusS-68

Hi Bigul

The issue sadly still exists. I've done everything you said (current php-version is 7.3 and i set the max execution time to 120.)

The summer vacations are coming and the booking is going strong, so I would appreciate it if we could resolve this problem asap!

Thank you very much.

June 24, 2019 at 5:54 pm #4079091

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have a couple of requests to track the issue.

1) Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

2) Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

The topic ‘[Closed] Site broken after translating to english and french’ is closed to new replies.