We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to set the home page?

Solution: You can select the homepage here: https://take.ms/qGQ14

This topic contains 2 replies, has 2 voices.

Last updated by giacomoC-11 4 months ago.

Assigned support staff: Riffaz.

Author Posts
July 13, 2019 at 3:47 pm #4203761

giacomoC-11

I am trying to:I added a Spanish home page

Link to a page where the issue can be seen:hidden link

I expected to see:my home page

Instead, I got:a test post

As soon as i added the Spanish home page, my site went down. If I append 'home' to the url, though, I get to my home page. My site is live, and I need it back up. Why is the Spanish home page causing routing issues?

July 14, 2019 at 3:55 pm #4205833

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Have you selected the homepage here? hidden link

Please provide debug info for better and faster help: https://wpml.org/faq/provide-debug-information-faster-support/
I am enabling the debug info for next reply

Let me know.

Regards,
Riffaz.

July 15, 2019 at 5:51 am #4207297

giacomoC-11

My issue is resolved now. Thank you!