This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
June 12, 2019 at 7:22 am

samA-7

Wordpress just showed me the new update to Woocommerce Multilingual.

I have proceeded to update it and the portal has gone down and entered Recovery Mode.

To function normally, I have to deactivate the plugin.

The error shown is as follows:

See picture

======================================================
An error of type E_ERROR was caused in line 53 of the file /home/sitandpirm/wailele/wp-content/plugins/woocommerce-multilingual/vendor/twig/twig/lib/Twig/TokenParserBroker.php. Error message: Uncaught TypeError: Argument 1 passed to Twig_TokenParserBroker::addTokenParser() must be an instance of Twig\TokenParser\TokenParserInterface, instance of Twig_TokenParser_For given, called in /home/sitandpirm/wailele/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php on line 1507 and defined in /home/sitandpirm/wailele/wp-content/plugins/woocommerce-multilingual/vendor/twig/twig/lib/Twig/TokenParserBroker.php:53 Stack trace: #0 /home/sitandpirm/wailele/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php(1507): Twig_TokenParserBroker->addTokenParser(Object(Twig_TokenParser_For)) #1 /home/sitandpirm/wailele/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php(1459): Twig_Environment->initExtension(Object(Twig_Extension_Core)) #2 /home/sitandpirm/wailele/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php(1381): Twig_Environment->initExtensions() #3 /home/sitandpirm/wa

=========================================================

June 12, 2019 at 7:54 am #4001387

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

I apologize for the inconveniences, ee are having some issues publishing the latest WCML version 4.6.4. I have accessed to your site and I've installed the previous version while we solved it.

I kindly ask you to postpone your update until all our WPML package is available.

Thank you for your understanding,
Andrés

June 12, 2019 at 8:15 am #4001589

samA-7

Gracias Andrés.

Esperaremos a la actualización correcta.

Como sabremos que la siguiente actualización es la que funcionará correctamente?

Seguirá siendo la 4.6.4? o 4.6.5?

June 12, 2019 at 8:32 am #4001905

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

En este momento hemos revertido, y ya no está disponible, la versión 4.6.4 para evitar cualquier confusión.

Esperamos haber solucionado este problema en las próximas horas y publicar todo el nuevo paquete de WPML.

Gracias por tu comprensión.
Saludos

June 12, 2019 at 9:36 am #4002599

sergioC-8

Hello
j'ai le même problème et je trouve grave de publier un plugin comme ça.
Je n'avais pas accès à l'admin du site,

Fatal error: Uncaught TypeError: Argument 1 passed to Twig_TokenParserBroker::addTokenParser() must be an instance of Twig\TokenParser\TokenParserInterface, instance of Twig_TokenParser_For given, called in /home/clients/159c29b62829e26e968ab50747391232/web/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php on line 1507 and defined in /home/clients/159c29b62829e26e968ab50747391232/web/wp-content/plugins/woocommerce-multilingual/vendor/twig/twig/lib/Twig/TokenParserBroker.php:53 Stack trace: #0 /home/clients/159c29b62829e26e968ab50747391232/web/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php(1507): Twig_TokenParserBroker->addTokenParser(Object(Twig_TokenParser_For)) #1 /home/clients/159c29b62829e26e968ab50747391232/web/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Environment.php(1459): Twig_Environment->initExtension(Object(Twig_Extension_Core)) #2 /home/clients/159c29b62829e26e968ab50747391232/web/wp-content/plugins/sit in /home/clients/159c29b62829e26e968ab50747391232/web/wp-content/plugins/woocommerce-multilingual/vendor/twig/twig/lib/Twig/TokenParserBroker.php on line 53

Merci de me donner une solution.

Cordialement

SC

June 12, 2019 at 9:41 am #4002671

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Pouvez-vous installer la version WooCommerce Multilingual 4.6.3 depuis le lien suivant :
https://wpml.org/account/downloads/

Or, si le problème persiste, n'hésitez pas à ouvrir un autre ticket pour pouvoir vous aider.

Cordialement

July 5, 2019 at 9:38 pm #4154013

samA-7

My issue is resolved now. Thank you!