This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by veraK 2 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
July 17, 2019 at 10:46 am #4228835

veraK

I am trying to: Change the site description in Hebrew (sorry, I realize you don't speak it, but this is my issue)

Link to a page where the issue can be seen: hidden link

I expected to see: (I don't know if you can see the Hebrew script) "גישה המביאה תוצאות ברמה אחרת"

Instead, I got: "הכשרה לאיכות בגישה מיוחדת, המביאה תוצאות ברמה אחרת."

I have tried:
- To change in the Settings, General tab. It shows the wrong line, I change it - it reverts to the wrong line.
- To change in Customized. It shows the correct line.
- To translate in String Translation. It shows a third option, neither or the above (previous description version). And I cannot change there, as it is shown as the original line, English is the translation.
- To check in the database. Table wp_options has the correct line.
I don't know where it takes the line from or how to change it.
Please help,
Thank you,
Vera

July 17, 2019 at 11:03 am #4229107

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. It seems your string is showing wrong flag in WML >> String Translation page. If so then you can change the language of a certain text domain, please go to WPML >> String Translation and click the "Languages of Domains" link ( screenshot attached). Here, you can select the domain and change the Hebrew language to other language.

If you want to change some specific string default language to other language then you can do it by selecting required string checkboxes and select new language from ‘Change the language of selected strings’ dropdown as you can see in the attached screenshot.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/string-translation/#original-language-of-strings

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

July 18, 2019 at 3:38 pm #4240251

veraK

Noman,
No, that is not the problem, and I am aware of this one from previous troubles.
The string is showing the correct symbol, the Hebrew one. It shows the wrong string in it. It shows the correct language, and even the correct phrase in the correct language.
The problem is, again, that in the header of the site this correct phrase doesn't show. Instead, it shows a different phrase in Hebrew (the correct language).
Vera

July 18, 2019 at 4:36 pm #4241083

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

July 21, 2019 at 12:36 pm #4252157

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Sorry for the delay, we ran into the weekend. Thanks for the login info. I am working on this issue and get back to you with my findings.

Thank you for your cooperation and patience.

July 21, 2019 at 5:11 pm #4252859

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have enabled error reporting in your site by adding below code in wp-config.php file:

 // Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

and found below errors in wp-content/debug.log file:

[21-Jul-2019 10:55:05 UTC] PHP Notice:  Undefined index: addons-for-elementor/freemius in /home/eichut2/public_html/wp-content/plugins/press-elements/libs/freemius/start.php on line 173
[21-Jul-2019 10:55:05 UTC] PHP Notice:  Trying to get property of non-object in /home/eichut2/public_html/wp-content/plugins/press-elements/libs/freemius/start.php on line 178
[21-Jul-2019 10:55:05 UTC] 

These errors were coming from ‘Press Elements - Widgets for Elementor’ plugin so I disabled that plugin and after that I have tried to update Tagline in each language by switching different language using the Language Switcher in the top of the WP Admin panel from Settings >> General and it’s updating correctly.

Then I activated ‘Press Elements - Widgets for Elementor’ plugin again and still Tagline updating correctly from Settings >> General.

Could you please check and confirm?

Thank you

July 21, 2019 at 5:11 pm #4252861

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have enabled error reporting in your site by adding below code in wp-config.php file:

 // Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

and found below errors in wp-content/debug.log file:

[21-Jul-2019 10:55:05 UTC] PHP Notice:  Undefined index: addons-for-elementor/freemius in /home/eichut2/public_html/wp-content/plugins/press-elements/libs/freemius/start.php on line 173
[21-Jul-2019 10:55:05 UTC] PHP Notice:  Trying to get property of non-object in /home/eichut2/public_html/wp-content/plugins/press-elements/libs/freemius/start.php on line 178
[21-Jul-2019 10:55:05 UTC] 

These errors were coming from ‘Press Elements - Widgets for Elementor’ plugin so I disabled that plugin and after that I have tried to update Tagline in each language by switching different language using the Language Switcher in the top of the WP Admin panel from Settings >> General and it’s updating correctly.

Then I activated ‘Press Elements - Widgets for Elementor’ plugin again and still Tagline updating correctly from Settings >> General.

Could you please check and confirm?

Thank you

July 21, 2019 at 5:50 pm #4252883
veraK

Noman,
As usual, you work this magic amazingly. Thank you.
It shows correctly.
I had another question I need to ask after this.
In the Woocommerce I have enabled multi-currency.
It works fine in the Admin, but on the site, it doesn't show the currency symbol, but a box sign. Do you know what to do to fix it?
Thank you,
Vera

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/doesnt-show-the-currency-symbol-but-a-box-sign/

July 22, 2019 at 8:47 am #4254971

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Glad to see your site description issue is resolved. To handle currency symbol issue, I have created a new ticket since this is a separate issue. Here is the link to the new ticket: https://wpml.org/forums/topic/doesnt-show-the-currency-symbol-but-a-box-sign/

You may mark this ticket as resolved and we will continue to work on the new ticket.

Thank you for your cooperation and patience.

July 22, 2019 at 8:54 am #4255053

veraK

My issue is resolved now. Thank you!