Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
After upgrading to WCML 4.0, I have the following error:

PHP Fatal error: Class 'WCML_Widgets' not found in /xxx/woocommerce-multilingual/inc/class-woocommerce-wpml.php on line 78

Solution:
- Deactivate your WooCommerce Multilingual (WCML).
- Remove it.
- Download a new fresh version from:
https://wpml.org/account/downloads/
- Upload and activate it.

Relevant Documentation:
https://wpml.org/documentation/related-projects/woocommerce-multilingual/

This topic contains 4 replies, has 3 voices.

Last updated by Andrés 3 years, 1 month ago.

Assigned support staff: Andrés.

Author Posts
December 5, 2016 at 5:00 pm #1151832

jean-francoisB-6

Site is down as well as admin
WCML_Widgets class is not loaded.
However, I can access partially through a modification of class-woocommerce.php, adding a copy of the class WCML_Widgets at the end of the file. This way I can have access to my admin. What can I do.
I am trying to: work...

URL of (my) website where problem appears: hidden link

I expected to see:

Instead, I got in my LOGS:
mod_fcgid: stderr: PHP Fatal error: Class 'WCML_Widgets' not found in /var/www/vhosts/vps156490.ovh.net/horseguard-canada.com/docs/wordpress/wp-content/plugins/woocommerce-multilingual/inc/class-woocommerce-wpml.php on line 78

Steps to duplicate the issue: just update the home page. But now I have loaded the missing class... It appears a bad : Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'remove_storefront_sidebar' not found or invalid function name in /var/www/vhosts/vps156490.ovh.net/horseguard-canada.com/docs/wordpress/wp-includes/plugin.php on line 524, now.

December 5, 2016 at 5:06 pm #1151840

marcoB-55

if you updated to wcml 4.0, reinstall the plugin
https://wordpress.org/support/topic/fatal-error-2356/

December 5, 2016 at 7:06 pm #1151922

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Jean-Francois and Marco,

Welcome to WPML support forum.

Thank you, Marco, you are right. There was a glitch in the publishing process. For solving this situation, please:
- Deactivate your WooCommerce Multilingual (WCML).
- Remove it.
- Download a new fresh version from:
https://wpml.org/account/downloads/
- Upload and activate it.

Does it solve your issue?

Best regards,
Andrés

December 5, 2016 at 7:09 pm #1151925

jean-francoisB-6

Hi Andrés and Marco,
Thank you for your help,
perfect for me,

many thanks !

JF

December 6, 2016 at 8:29 am #1152284

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I'm glad to know that it works.
Have a nice day!
Andrés