This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.65 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by lubaY 3 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
July 1, 2019 at 11:03 pm

lubaY

I am trying to:
Activate WPML

Link to a page where the issue can be seen:
Home page (or any page) after the Plugin is activated: hidden link

I expected to see:
The working website

Instead, I got:
Broken page... see attached screen.

July 2, 2019 at 12:00 am #4122511

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. I've noticed that you are using 40Mb of memory. The WPML requires at least 128MB: https://wpml.org/home/minimum-requirements/

Note that WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Please, could you increase the memory limit for WordPress? To do it, please open the wp-config.php file in the root of your WordPress installation and after the opening PHP tag, add these lines:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

E.g.:

<?php

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Then save the file and using your FTP client, upload wp-config.php to your server.

Thank you.

July 2, 2019 at 8:07 pm #4129949

lubaY

I followed the instructions, updated the wp-config.php file as described. No change. Same error when activating WPML.

July 3, 2019 at 11:45 pm #4139319

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. Please, could you enable debug to see if any error message is displayed beside this friendly WordPress message? To do it, please check the steps in our documentation: http://wpml.org/documentation/support/debugging-wpml/

Then try again to check the problem. If any error message appears, please paste here in the post for me to see.

Thank you.

July 4, 2019 at 3:31 am #4140101

lubaY

Fatal error: Uncaught InvalidArgumentException: Argument $language_code must be a non empty string. in /home/boomerang_ncclf/cafreshworks.com/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-translation-element.php:76 Stack trace: #0 /home/boomerang_ncclf/cafreshworks.com/wp-content/plugins/sitepress-multilingual-cms/compatibility/visual_composer/class-wpml-compatibility-plugin-visual-composer-grid-hooks.php(61): WPML_Translation_Element->get_translation(false) #1 [internal function]: WPML_Compatibility_Plugin_Visual_Composer_Grid_Hooks->replace_grid_id(Array) #2 /home/boomerang_ncclf/cafreshworks.com/wp-content/plugins/sitepress-multilingual-cms/compatibility/visual_composer/class-wpml-compatibility-plugin-visual-composer-grid-hooks.php(46): preg_replace_callback('/(\\[vc_basic_gr...', Array, '[vc_column][vc_...') #3 /home/boomerang_ncclf/cafreshworks.com/wp-includes/class-wp-hook.php(288): WPML_Compatibility_Plugin_Visual_Composer_Grid_Hooks->vc_shortcode_content_filter('[vc_column][vc_...') in /home/boomerang_ncclf/cafreshworks.com/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-translation-element.php on line 76

July 5, 2019 at 9:03 pm #4153969

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. From the error message, it seems that the problem is related to some shortcode that you are using in your page builder that is not correct (Post Grid "vc_basic_grid").

From what I noticed, when I activate WPML the plugin has not yet been configured. I'll attach an image for you to see. You must configure WPML before visiting the homepage.

If the problem persists, please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

July 5, 2019 at 9:23 pm #4154001

lubaY

Activating the Plugin (although the site "crashes") and then configuring fixed the issue. Thank you!