This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Some sites run into performance issues because of other plugins. It can be due to compatibility issues with WPML or other problems in the code of those plugins.

If you are running into performance problems, first follow our FAQ entry about preventing performance issues with WPML. This FAQ includes a number of simple steps to follow.

In case you want to profile your site's performance and get to the bottom of performance problems, follow the guide for debugging performance problems.

Tagged: 

This topic contains 120 replies, has 4 voices.

Last updated by George Botsev 1 year, 11 months ago.

Assigned support staff: George Botsev.

Author Posts
October 5, 2017 at 9:06 am #1392167

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Our developers are already working on the issue with compatibility with the plugin for invoices and packing slips.
When I have news there, I will get back to you and update you about that.

Thank you for confirming that the refund mail is now better.

About the VAT label. In my test environment - I have it translated. e.g. "BTW Nummer:"

Could you perhaps give me an example what to look for, please?
Maybe I am missing something?

October 5, 2017 at 9:17 am #1392188

adriO

Hi George,

Thank you for your quick reply. I have uploaded a jpg of an credit note created by the plugin and attached to the refund emails. So, it is on the PDF credit note.

At the bottom of the credit note you can see the Total, the VAT and the Grand Total.
As you can see is the label of the VAT still in English where the rest of the Credit Note is in Dutch.
This happens with credit notes only. It should be 21% NL BTW.

When you view the edit order screen you only see the Dutch label, see screenshot. Therefor it is a puzzle to me where "the system" gets the English version from.

I hope you can work with it and I hope to hear.

Best wishes,

Adri

October 5, 2017 at 9:59 am #1392260

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Thank you for the screens.
I will check this out.
It appears that I have that switched off on my local testing site so I was not seeing it.

October 5, 2017 at 11:17 am #1392388

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Okay, I tested once more time by reinstalling the duplicator package.
However, I could not get the VAT label on the refund e-mails.
I got the VAT label on order-complete e-mails and it is translated to NL BTW

Could I please ask you for more details on how to reproduce the same?
Maybe a screencast with your steps? Or just your steps here in text?

October 6, 2017 at 5:01 am #1393157

adriO

Hi George,

It is not in the refund emails themselves. It is in the generated PDF Credit note.

I don't do anything fancy.

1) I create an order in Dutch and choose for cheque payment (for testing purposes)
2) I tick the complete button on the order screen.
An order complete email is sent with a PDF Invoice attached. Note that on the Invoice the VAT label is "21% NL BTW".
3) I go to the edit order screen of that order.
4) I Revoke access to the download.
5) I hit the refund button and fill in the quantity, amount and VAT amount.
6) I hit the refund manually button (because it was a cheque payment I can not hit Automatically)
7) A refund email is sent with the PDF credit note attached.
In the PDF is all of the credit note in Dutch except for the VAT label on the bottom right oft the PDF credit note.

I hope this clears some thing up for you.

Regards,

Adri

October 6, 2017 at 1:13 pm #1393665

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Thank you!
You provided me with very crucial information about how to reproduce the problem.
I always ended up without having a VAT field, because I just presed the refund button and entered the amount (the total) and it was all good even in the credit note (there was just no field for VAT).
I see that there is an additional field that one can use to refund - that is provided by your VAT plugin and the problem is coming from there.

October 6, 2017 at 2:30 pm #1393782

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Okay, I am not sure how the vat plugin makes this, but since that plugin is not in our compatible plugins list, I have to escalate it as a compatibility issue.
Do you have any connection with the plugin author?
Perhaps you can also encourage him to work with our compatibility team.

October 6, 2017 at 2:39 pm #1393798

adriO

I will try to find out what you mean and also try to contact the plugin author. In the past I had some contact moments with hi,. You will hear from me as soon as possible. Thank you for your effort and have a nice weekend.

Best wishes,

Adri

October 6, 2017 at 2:48 pm #1393818

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

It would be nice if you could provide a means to contact the author - it might make our compatibility team life easier.
I have escalated the issue to our compatibility team. When they respond - I will be sure to get back to you asap.
Have a nice weekend you too!

October 28, 2017 at 7:03 am #1414632

adriO

Hi George,

You can reach the author of the VAT plugin at hidden link.
However I strongly doubt it that it is the cause of the problem. Deactivating the plugins brings no change what so ever.

What I see is that when the plugins are deactivating still a field is available for VAT on the refund screen. See screenshot_1.png in the red circle. Note that the label is in Dutch.
Next to that you can see in screenshot_2.png that the VAT label in the reporting area of the VAT plugin is also in Dutch.

It is still puzzling me why unticking the option "Assume all strings are in English" solves the issues at hand. The Subject and Title of the order completed email and the VAT label on the credit note as well. Of course is it not the way to go to leave it unticked because that is slowing down the site. As you know I've contacted the author of the invoice plugin and he claims that it is NOT in his plugin code. He has contacted WPML but I do not know what the status is.

I hope you can work with it.

Best wishes,

Adri

October 30, 2017 at 7:21 am #1415276

adriO

Hi George,
Here I am again. Did you have a nice weekend?

I did some further digging and this came up:
When the invoice plugins are activated the subject and title translations are going wrong as you know. Deactivating the plugins makes it right. Unticking the "Assume" option also. None of those are preferred as you can imagine.

I tried to add the invoice to the "on hold" status email and that works fine. English emails for an English order and Dutch emails for a Dutch one. I thought that it maybe could be corrected when I delete the strings involved an translate them again. So, I did. That did not help.

BTW, do you want me to open a new ticket for this issues (emails and VAT label)? Those two seems to be related because unticking the "Assume" option shows me the correct Dutch VAT label on the credit notes.

I hope to hear from you.

Best wishes,

Adri

October 30, 2017 at 8:44 am #1415344

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello Adri!
Good to hear from you!
I am just fine. I hope that everything is good with you too.

No need to create additional tickets - we already have this escalated to our compatibility team.
Thank you for your tests. I have forwarded the information to our compatibility team.

For now, I have no news about the problem, but as soon as I have something I will let you know.

October 30, 2017 at 2:51 pm #1415812

adriO

Hi George,

I'm fine thank you.

I have contacted the Invoice plugin developer once more with the latest information.
He wrote an email to me in Dutch. I will try to give you a proper translation of his text below. Perhaps it is useful to you or to the Compatibility Team.

------------- start email ------------
"Without PDF Invoices is it all ok with the email texts, with PDF Invoices suddenly problems are rising with the translations. I have tested it with the free version of PDF Invoices. In this free version is nothing what is even slightly near String Translations, WPML functions or email texts, so that is remarkable. I told this to WPML and I suspect that it could be caused by the fact that I use 'woocommerce' strings in my plugin code (next to the usual 'woocommerce-pdf-invoices-packing-slips' strings). That those strings are used should of course never be the cause that the whole system is going up side down.

The string used as VAT tax label is copied / created by woocommerce at the moment the refund is created. I suspect that WPML does not have this process under control, or maybe too much, because these strings never surfaces on the front end with normal use, without the use of plugins working with refund data. What you see in WooCommerce are just all totals from the original order, corrected with quantities / amounts from the refund. The strings line items and taxes from the refund itself are not participating.

That is my analysis of the situation but I don't know if you or WPML can do anything with it.

Problem 1 (with the email strings), is imho really a WPML bug and should relatively be easy to backtrace it to source by the WPML developers in a simple setup with only WooCOmmerce + WPML + PDF Invoices (free) https://wordpress.org/plugins/woocommerce-pdf-invoices-packing-slips/.
As noted I suspect that this is caused by references to the woocommerce text domain in the plugin but I'm not sure of it.'

------------- end email ------------

I hope this is useful to you.

Best wishes,

Adri

October 30, 2017 at 3:26 pm #1415874

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Thank you for the additional information.
Our compatibility team is still investigating the problem and yes - the problem with the PDF invoices plugin could be caused by some code that they use or their compatibility class that they have for WPML.
The other issue with the VAT label is more strange, and yes - if he copies somehow the string and uses its value, and then alters it - this is why it is not working properly. WPML String Translation works by creating an md5 checksum based on all string properties - domain, context, content . If that checksum is changed - then the translation could not happen.
I guess this is what is happening - if he changes the domain of the string.

October 30, 2017 at 3:45 pm #1415901

adriO

Hi George,

Finally a break-through..... yeah.

On the settings page woocommerce -> settings -> emails you can click on the 'configure' button on the right of the order completion email. When landed on the configuration page we see two fields: subject and email heading. When removing the customized texts and reverting to de defaults the order completed email is proper translated. I hope it will help you to pin down the failure in the code.

Next, and thank you for your reply, I really don't understand what you are telling me about a checksum.... And who is he? Can you please elaborate a little bit more?

Regards,

Adri