Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 9 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
February 6, 2019 at 5:42 pm #3167001

Janatan Snippert

Hi,
When a user is not logged in and open none default language page is broken. As thread "https://wpml.org/forums/topic/wpml-not-working-correctly-for-non-logged-in-users/" suggested, I turned on the "Store a language cookie to support language filtering for AJAX", yet it didn't fix my problem.
I disabled "WP Rocket" and the problem still exist,
I put the simplest header and footer and erased All content of the page, again problem exist.

I also find an error on pages which are broken:

Request URL: <em><u>hidden link</u></em>
Request Method: GET
Status Code: 500 
Remote Address: 176.31.17.146:443
Referrer Policy: no-referrer-when-downgrade
February 7, 2019 at 2:27 am #3168172

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

February 12, 2019 at 6:42 pm #3190431

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, check my private reply. Thanks!

February 13, 2019 at 12:32 pm #3193949

Janatan Snippert

Hello
migration is initiated. it says it may take 4 hours!

February 13, 2019 at 5:03 pm #3195557

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, let me know when you are ready. Have a nice day.

February 14, 2019 at 10:25 am #3198776

Janatan Snippert

Hi
I updated wpml and checked my log file, I got this error:

PHP Notice:  Trying to get property of non-object in /home/mysite/domains/mysite.com/public_html/wp-includes/taxonomy.php on line 3949

this line is related to:

$termlink = apply_filters( 'pre_term_link', $termlink, $term ); 

and only plugin which add something to this filter is wpml:

add_filter( 'pre_term_link', array( $this->term_link_filter, 'replace_slug_in_termlink' ), 1, 2 ); // high priority 

this is in:

wp-content/plugins/wpml-string-translation/classes/slug-translation/class-wpml-slug-translation.php

I commented this line and the main problem still exist.
Maybe it could be a clue to find the problem.

February 14, 2019 at 4:34 pm #3200946

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, confirm if the migration is done and we'll proceed with the investigation process including the cause of the mentioned PHP notice. Thank you for your collaboration, have a nice day.

February 16, 2019 at 6:45 am #3207500

Janatan Snippert

Hello,
migration is complete

February 17, 2019 at 9:37 am #3208841

Janatan Snippert

I migrated site several times, each time it says the process is completed, yet when I want to load the url which you gave me, it return 500 error

February 19, 2019 at 1:36 am #3214537

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates, in this case, let's try another method: To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

February 25, 2019 at 7:55 pm #3241845

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, check my private reply above. Thanks!

February 27, 2019 at 6:59 pm #3252242

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Just a follow up here to confirm your issue is indeed a cache issue as I wasn't able to replicate it anymore, your root page is working as it should, no issue to the layout is seen anymore. Please, let me know if you still see the issue after a cache clean up. Have a nice day.

March 3, 2019 at 12:00 pm #3266104

Janatan Snippert

I cleaned up the cache and the issue still exist.
Actually, every time I clean the cache, problem arises, and I have to go to each page and clean up the cache for that specific page.

March 8, 2019 at 5:51 pm #3294734

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I tried your website using two different browsers Firefox and Chrome and no issue is seen. Can you please confirm if you see the issue when trying to access your website using another device, browser and internet provider? Thank you for your collaboration, have a nice day.

March 9, 2019 at 8:32 am #3297316

Janatan Snippert

Hello,
I uploaded a video about how to reproduce the problem.

hidden link