This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Rohan Sadanandan 2 months, 3 weeks ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
July 24, 2019 at 12:24 pm #4274353

peterB-98

When i change language Version and then click on any category link or any sub category link it redirect to slovak version instead of eglish version so can you please check what is the issue

Here is the link :- hidden link

July 24, 2019 at 3:46 pm #4276247

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

Please enable the Debug Information so that we can provide faster support.

Please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

I just clicked on the category & it was working fine.
Home Page > Category >RADIATOR WITH STAND A

Could you please let me know the URL or menu items you are having the issue with?

Thanks,
Rohan

July 25, 2019 at 5:07 am #4279087

peterB-98

Another strrange issue is when i change anything on admin english side like category or product the suddenly my site stopped work and it shows 500 error.

RewriteBase ?lang=en this line added to .htaccess so is it any issue with this. Please check attachment

July 25, 2019 at 8:02 am #4280443

peterB-98

The English language menu does not work properly.

Here are the steps to reproduce the problem:

1. Start on page hidden link
2. When I click menu item Infrabox version, I am redirected to the page hidden link which is a SLOVAK version page
It is supposed to redirect to hidden link

Maybe it has something to do with the .htaccess problem which shuts down the whole site???

July 25, 2019 at 9:37 am #4281395

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I just checked hidden link & clicked on the Infrabox version menu item and it was redirected to hidden link

Also, may I know why do you add that code to .htaccess
If it's not required, you can remove the code.

Also, please enable the Debug Information so that we can provide faster support.

Please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Thanks,
Rohan

July 25, 2019 at 10:59 am #4282097

peterB-98

Hi,

the problem with the links is now resolved, it was probably an issue with the cache.

However, the problem with .htaccess is probably still unresolved.

Some process MODIFIES .htaccess without me wanting it and adds "RewriteBase ?lang=en" which causes an Internal server error

# BEGIN W3TC Page Cache core
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase ?lang=en
RewriteCond %{HTTPS} =on
RewriteRule .* - [E=W3TC_SSL:_ssl]

The original, working .htaccess has this line instead:

RewriteBase /

Canm you check whether this is caused by your plugin? I suspect it is and it is not good because caused Internal server error and the site is inacessible.

Do you still need that DEBUG information active to investigate this?

July 25, 2019 at 1:54 pm #4283833

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Based on the debug information, your WPML & the add-on plugins are out of date.
Could you please update WPML & the add-on plugins?

Also, the WP Memory limit is set to 40MB. At least 128 MB is required for WPML.
Could you please update the same?
You can read the minimum requirements here: https://wpml.org/home/minimum-requirements/

Thanks,
Rohan

July 25, 2019 at 2:33 pm #4284259

peterB-98

I TRIED to update, now the whole site is in the shitter!

Fatal error: Call to undefined function icl_get_string_id() in /home/infrabox/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/class-wpml-enpoints-support.php on line 107

July 25, 2019 at 3:40 pm #4284867

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

It seems that some file was corrupted while updating. Please try downloading the WPML directly from your client area install it manually, here is the documentation link: https://wpml.org/faq/install-wpml/

NOTE:
Also, make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Please let me know if this solves the problem.

Thanks,
Rohan

The topic ‘[Closed] Site is not translation proper’ is closed to new replies.