This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Site is not using the Advanced Translation Editor for pages used classic editor earlier

Solution:

User was using classic editor for this page before activating the ATE? It's a known issue. Please go to WPML->Translation Management-> Send the page for translation and then took the translation job and it will be opened up in the ATE: https://wpml.org/documentation/translating-your-contents/#using-translation-management

I mean you just have to re-do these steps for the pages you have this issue: https://wpml.org/documentation/translating-your-contents/

This topic contains 14 replies, has 2 voices.

Last updated by richardT-24 3 weeks, 4 days ago.

Assigned support staff: Riffaz.

Author Posts
September 16, 2019 at 12:23 pm

richardT-24

I am trying to: translate some pages (e.g. FAQ) using the Advanced Translation Editor.

Link to a page where the issue can be seen:hidden link

I expected to see: When I click on the cogs icon next to the page in the Dashboard Pages (see attached image), I expect this to redirect me to ams.wpml.org to auto translate the content.

Instead, I get directed to the translation page on my site itself. In Dashboard -> WPML -> Translations.

September 16, 2019 at 2:13 pm #4581189

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

You were using classic editor for this page before you activate ATE, right?
It's a known issue.
Please go to WPML->Translation Management-> Send the page for translation and then took the translation job and it will be opened up in the ATE.

I mean you just have to re-do these steps for the pages you have this issue: https://wpml.org/documentation/translating-your-contents/

Hopefully, this will fix the issue.

let me know your results, please.

Regards,
Riffaz.

September 17, 2019 at 8:43 am #4586481

richardT-24

Hello - Thanks for your reply.

Yes, I can confirm that I am using the classic editor. I have the 'WPBakery Page Builder' plugin on my site that does not work with Gutenburg, so do need to use classic editor.

Unfortunately this has not fixed the issue on my site. I have carried out the steps outlined, but the 'Take and translate' button is still directing me to the translation page on my site itself, and not to ATE.

Thanks,
Rich.

September 18, 2019 at 7:06 am #4592893

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

So we have to dig this more.
I escalated this to our second tier support.
Please be patient till we get back to you again.

Regards,

September 18, 2019 at 11:34 am #4595827

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Could you please do these tests and get back to us?
- Does it happen with new content or old content?
- What if you modify or update content a little and then click translation?
- Did you try syncing ATE settings?
- go to the WPML -> Settings page and in the How to translate posts and pages section click
Synchronize translators and translation managers.

September 18, 2019 at 1:16 pm #4597051

richardT-24

Hi - Thanks for getting back.

Answers below...

====================

- Does it happen with new content or old content?

It happens with all New pages that I am creating.

Older pages that have not been updated seem to still be using the ATE as far as I can tell.

====================

- What if you modify or update content a little and then click translation?

Older pages previously translated via the ATE and that have been recently updated in the main/source language have a different issue. On the 'Dashboard->Pages' page, when I click on the 'cogs' icon to translate a version, it takes me to a page stating:
------------
The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.
------------

No admin emails have been received at all. But, I can see this in my server error logs:

PHP Fatal error: Uncaught Error: Call to undefined function mb_ereg_replace_callback() in /home/****/public_html/*******/wp-content/plugins/wpml-translation-management/classes/xliff/class-wpml-tm-validate-html.php:423

I'm guessing this could well be related.

====================

- Did you try syncing ATE settings?

No, but I have done so now in the WPML -> Settings page, clicking 'Synchronize translators and translation managers', and this has had no effect that I can see.

====================

Thanks.
Rich.

September 20, 2019 at 4:16 am #4609733

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ok, your Translation Management file is corrupted.

Please:
1. disable WPML Translation Management
2. delete it (deleting the WPML TM will not delete your translations. Translation are in database)
3. download a fresh copy from https://wpml.org/account/downloads/
4. install and activate

Check your issue again.
Your site should work fine.

Let me know how it goes.

Regards,

September 20, 2019 at 9:44 am #4611079

richardT-24

Hi - I've done those steps. It hasn't changed anything.

Thanks,
Rich.

September 20, 2019 at 4:48 pm #4613671

richardT-24

Hi - Sorry to chase, but any update on this please?

My client has a press release that has been pushed back several days now due to this bug, and they are really chasing me. I do need to try and get it resolved as soon as possible.

Thanks,
Rich.

September 22, 2019 at 2:33 pm #4618745

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry for the delay. I do not work on fridays and saturdays.

I am consulting this with our developers.
We will update to you by Monday evening.

Regards,

September 24, 2019 at 5:44 am #4628111

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

We just noticed that your hosting is disables MBStrings: hidden link
This is required extension to run WPML.

A client from a similar issue mentioned that
"The new server didn't have "Multibyte String Extension" which has "mb_ereg_replace_callback". After installing the extension, the problem was solved."

So could you please ask your hosting provider to enable the MBString on your plan?
Also, ask them to increase the MaxInputVars to 10000

Please check the issue after that and let us know the results.

Regards,

September 24, 2019 at 9:07 am #4629387

richardT-24

Hello,

Thanks for those suggestions. I have done both.

I am still experiencing the issue.

Thanks

September 24, 2019 at 12:41 pm #4631667

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for this.

Our second tier support is checking this now.
Please be patient till we get back you again.

Regards,

September 26, 2019 at 10:23 am #4645643

richardT-24

Hello,

I've managed to get all my page translations working through the ATE now, so we can close this ticket. I honestly don't really know quite what happened to make it work.

I tried all the various page translation versions that were previously not being directed to ATE, and just one of them did go through to ATE (it hadn't previously gone to ATE, and all the others were still not going to ATE) - Once I had finalised the translation on that one page in ATE, all the others then started to work correctly. So I can only assume there was some sort of corruption on that version maybe that meant the queue could not progress perhaps ? I really have no idea, but anyway, they are all working again for now.

Many thanks for your help on this.

September 26, 2019 at 10:30 am #4645757

richardT-24

.