This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 24, 2018 at 9:59 pm

amelieG-3

I am trying to:
Get a decent speed.

Link to a page where the issue can be seen:
/boutique/

I expected to see:
A normal loading.

Instead, I got:
A slooooooow loading. It sometimes takes up to 20 seconds to load the main shop page.
If this issue can't be solved, I'm really considering switching to Polylang or any plugin that isn't so slow.

September 26, 2018 at 12:53 am #2765408

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Go to WPML -> Langues -> Réaliser des thèmes multilingues -> Deactivate this option -> Save the changes.
- Go to WPML -> Traduction de chaînes -> Auto-enregistrer les chaînes pour la traduction (bottom left) -> Click on 'Modifier' button -> Deactivate all options -> Save the changes.
- Go to Woocommerce -> Woocommerce Multilingual -> 'Paramètres' tab -> 'Dépannage' link (bottom right) -> Sync all products.

Could you tell me the result of this steps?

2.- Please increase the PHP Memory Limit to 512Mb
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 26, 2018 at 9:06 am #2766536

amelieG-3

Hello Carlos,

Thanks for your help. Unfortunately, I did all you asked and it looks like it's even worth now, it takes up to 26 seconds sometimes to load the shop page.
See the attached screenshot, WPML String Translation takes so long to load.
Is there anything I missed regarding the settings/configuration?

Thanks again,
Amelie

September 26, 2018 at 7:50 pm #2768537

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Amelie,
Thank you very much for your feedback.

I double checked the configuration in WPML and everything seems to be correct. I suspect that the cause of the performance issue might be an interacction problem.

I kindly ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins.
- Flush all cache memory that might exists.
- Double check if the issue persists with WPML plugins deactivated. If the issue persists then:
-- Deactivate all the plugins that are not related to WPML.
-- Switch for a moment to a WordPress default theme like Twenty Seventeen.
-- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Looking forward to your answer.
Best regards,
Carlos

September 26, 2018 at 9:26 pm #2768806

amelieG-3

Hi Carlos,

Tried everything you said and the result is pretty clear :
- with WPML : 20+ seconds to load the main shop page
- without WPML : 3-4 seconds to load the main shop page

I noticed deleting the terms speeds up the site but I need them them to front appear.
It looks like the site is super slow because WPML duplicates every products so each query is x by languages (I have 4 in my case). So let's say your have 50 products, it looks like the query is searching for the 200 (non) existing products...

It's such an issue cause nobody wants to wait for 20 seconds, you won't disagree.

Can you please tell me what's causing it? I don't mind re-thinking my code and stuff. And it's fine if you tell me WPML can't fit my needs, I just need to know.

Thanks a lot,
Amelie

September 26, 2018 at 9:57 pm #2768833

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Amelie,

This is not normal at all.

I can see that all of your products are translated or duplicated in the secondary languages. Could you tell me if this step solves the issue?
- Go to WPML -> Paramètres -> Traduction des types de publication -> Set 'Produits (product)' to 'Traduisible : affichez uniquement les éléments traduits' -> Save the changes.

Looking forward to your answer.
Best regards,
Carlos

September 30, 2018 at 6:33 pm #2776720

amelieG-3

Thank you Carlos, it could go faster but I'll play with cache, it's muuuch better than it used to be.
Can you please delete the private info?

Thanks a lot again!

October 1, 2018 at 2:51 am #2777083

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Amelie,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos