Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Izzi Hassan 3 weeks, 1 day ago.

Assigned support staff: Izzi Hassan.

Author Posts
October 28, 2019 at 7:10 pm

ivanM-14

Hi,
The website works very slowly since I installed the WPML plugin, if I deactivate it it works much lighter. In his day I eliminated a lot of chains, I went from about 40,000 to about 1,000, but the website was still slow. Also, I updated to version 4.3 and now to 4.3.1, but still slow.

The web page is hosted on a dedicated set server with a dedicated 2GB ram memory. The page has woocommerce installed with just about 20 products in two languages.

Can you help us to see if they find anything?

Thank you very much for your time.

Regards.

October 30, 2019 at 7:29 am #4852949

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for reaching out to WPML Support.

I took a quick look and the site seems to redirect me to the homepage no matter what I do, other than one product page (hidden link) Please let me know if this is due to work you are doing on the website currently.

I also tried to access the WP Admin but I got a "Forbidden - Sorry, your request cannot be accepted" error.

Please let me know how to recreate the slow performance and I'll be happy to assist you further!

October 30, 2019 at 7:40 am #4853075

ivanM-14

Hi Izzi.

Sorry I had a plugin to block by IP, I have already deactivated it.
You can try again.
Thank you

Iván Martos

October 30, 2019 at 5:26 pm #4858375

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you Ivan.

I have confirmed that I have access now. However, we are facing a higher than normal number of support requests at the moment so please give me some time to properly investigate the issue you are facing. I will update you as soon as soon as I have some information for you.

In the meantime, could you give me an example of a page that loads slowly for you, along with the current load times you see?

October 30, 2019 at 8:03 pm #4859169

ivanM-14

Hi Izzi,

Since this latest version 4.3.1 I detect that the website works a little faster, but still it is not enough, there is no specific url, it works slow when navigating between different sections.

Thanks for your time.

Regards.

October 31, 2019 at 1:59 pm #4864555

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Ivan,

It seems to run pretty fast for me. I didn't see anything in the backend that looks improperly configured.

Please understand that WPML will always come with a performance hit. Generally, you should be able to use a caching plugin like W3TC to speed up the pages.

I can try some debugging steps to try to clean up some of the WPML database tables as well as guage how much faster the site runs without WPML. However, we prefer not to work directly on a live website.

If you are able to create a staging copy of the site, please do so and send us credentials for that website. We can also set up a copy of your site on our servers to investigate further. but I will need your permission to do so.

I feel it would be best to try to create a copy on your server so that we can make sure the environment is the same as your live site.

November 6, 2019 at 4:51 pm #4900437

ivanM-14

Hi Izzi.

Good afternoon
Sorry for the delay.
We are going to make a copy on our server, in having it ready I pass you the access passwords.
Many thanks.

Regards.

November 7, 2019 at 6:54 am #4903005

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Ivan,

I appreciate the update and will wait to hear from you.

Best,
Izzi

November 8, 2019 at 5:23 pm
November 13, 2019 at 8:22 pm #4942583

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Ivan,

Thank you for setting up the staging environment. I just wanted to update that I have access and am testing to see if I can speed it up.

Please confirm that this environment is safe and backed up. If anyone else is also working on this server, please let me know so that I can back up before any major changes or tests.

Best,

November 14, 2019 at 8:13 am #4944537

ivanM-14

Hi Izzi.

The environment is safe and backed up.
There is no one working on that server.

You can do all the tests you want without problem.

Regards.

November 15, 2019 at 12:35 pm #4953971

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for confirming. I will update you soon.

Best,
Izzi

The topic ‘[Closed] Site is very slowly’ is closed to new replies.