This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 31 replies, has 2 voices.

Last updated by ilanaG 11 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
October 10, 2018 at 4:35 pm

ilanaG

I am trying to: save the Site Language as עברית (Hebrew), which is loaded in the menu

Link to a page where the issue can be seen: hidden link

I expected to see: עברית

Instead, I got: English, no matter how many times I save.

I also tried deleting the site title under string translation and that didn't help

October 11, 2018 at 10:22 am #2807561

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

This is because your WordPress site is installed in English and therefore you needed to "trasnalte" the Hebrew in this language as well.

I fixed this by doing the following steps:
- Reactivate the EN langauge
- Edit languages and change the English translation for HE lang to be עברית
- Deactivate the EN language again

Now as you can see, the language is showing as expected.

October 11, 2018 at 10:33 am #2807649

ilanaG

Hi, this is not the issue and does not solve the problem. I am talking about changing the MAIN site language to Hebrew under General Settings.

October 12, 2018 at 1:07 pm #2812078

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Oh my - I completely missed this didn´t I? My apologies.

1. If you deactivate WPML are you able to set the language? It might be that you do not have the required language files to do this change.

In any case, I´m looking at this now.

October 12, 2018 at 1:31 pm #2812149

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello again

There is a lot of security on your site which is great but it also mean that I am limited in being able to troubleshoot the problem.

I was able to use the FTP access to activate the debug mode and saw this message :
WordPress database error: [Unknown column 'st.mo_string' in 'field list']
SELECT s.id, st.status, s.domain_name_context_md5 AS ctx , st.value AS translated, st.mo_string AS mo_string, s.value AS original, s.gettext_context FROM wpal_icl_strings s LEFT JOIN wpal_icl_string_translations st ON s.id=st.string_id AND st.language='en' AND s.language!='en' WHERE s.context = 'admin_texts_wpseo_social' LIMIT 1000 OFFSET 0

This suggest to me that there is a table field missing. Could you please use the ARI Adminer plugin or your CPanel phpMyAdmin to check if the icl_string_tranlsations table on your site has the field "mo_string"?

Thanks for letting me know.

October 12, 2018 at 2:02 pm #2812252

ilanaG

I don't know what was done here, but there were NO error messages before you started making changes on the site and now there are all sorts of errors. I never saw this error message before. I'm very frustrated and disappointed. I have to be away from the computer for the next day and a half so I'm going to change the credentials until I can take a closer look.

October 12, 2018 at 2:05 pm #2812254

ilanaG

By the way, when I would deactivate WPML, yes I was able to make the change. Which files exactly do I need? I checked the wp-content/languages folder and it looked like everything is there.
I will follow up about your other question regarding the missing string later.
In the meantime I am restoring a backup in order to hopefully remove the error messages.

October 12, 2018 at 2:06 pm #2812255

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

The "errors" were only debug messages after activating the Debug log.

The debug log has been turned off again.
I visited your site and I do not see any error messages - please upload a screenshot of what you are talking about.

Thanks

October 12, 2018 at 2:09 pm #2812261

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I believe the reason you cannot execute the change when WPML is active is due to a missing field in a database table.

If you are able to change the language when WPML is deactivated, then you do not have any language files missing.

October 12, 2018 at 2:22 pm #2812288

ilanaG

1) Re: Errors - I am attaching an image of what I saw. I didn't realize it was because you were momentarily checking the debug log. All I know is someone else went to the site and this is what they saw. Then I went to the site and saw it too.

2) The homepage is showing up as practi-food.com/?lang=he Before the suffix was not showing up. The url was just practi-food.com

October 12, 2018 at 2:23 pm #2812300

ilanaG

This is STILL showing up on my mobile browser

October 12, 2018 at 4:56 pm #2812685

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Debug messages
To turn off all error messages please make sure the following line in your wp-config.php is set to "false" and not "true".

define( 'WP_DEBUG', false ); 

2. URL
You wrote: "The homepage is showing up as practi-food.com/?lang=he"

This would happen if the WPML default language is set as English. Please make sure it is set to Hebrew.

If you have caching somewhere, this may be interfering with what current settings are showing and what the frontend is showing.

3. JUST TO REVIEW
The only action on my part was to activate the Debug mode in the wp-config.php and to confirm that you could indeed set the system language to HE when WPML was deactivated (which you did as well)

No other configuration was touched or changed.

October 16, 2018 at 8:13 am #2820008

ilanaG

1. I never made any change that would cause practi-food.com/?lang=he to appear. I do not understand what you did at first, where you activated and deactivated English. But fortunately that is gone.

2. As for the issue at hand, you wrote:

  • I was able to use the FTP access to activate the debug mode and saw this message :
    WordPress database error: [Unknown column 'st.mo_string' in 'field list']
SELECT s.id, st.status, s.domain_name_context_md5 AS ctx , st.value AS translated, st.mo_string AS mo_string, s.value AS original, s.gettext_context FROM wpal_icl_strings s LEFT JOIN wpal_icl_string_translations st ON s.id=st.string_id AND st.language='en' AND s.language!='en' WHERE s.context = 'admin_texts_wpseo_social' LIMIT 1000 OFFSET 0

    This suggest to me that there is a table field missing. Could you please use the ARI Adminer plugin or your CPanel phpMyAdmin to check if the icl_string_tranlsations table on your site has the field "mo_string"?

  • >> I still am unable to change the site language under general settings to Hebrew. It doesn't save when WPML is active. I took a look at the database via phpMyAdmin and checked the icl_string_translations table. A search for "mo_string" turned up empty. I still see those error messages when debug is set to true (on staging).

    October 16, 2018 at 10:59 am #2820678

    Yvette
    Supporter

    Languages: English (English ) Spanish (Español )

    Timezone: Europe/Madrid (GMT+02:00)

    So, yes, as long as the database inconsistency is present, you will not be able to save the value you are trying to save as the PHP error will then interrupt any save process. As the table is a WPML table, this is why the error only happens when WPML is active.

    You will need to add the missing field to the table structure exactly as indicated the image in my response:
    https://wpml.org/forums/topic/site-language-in-general-settings-not-saving/#post-2812149

    You will need to do this using PHPmyAdmin --OR-- have success to install and use ARI Adminer plugin.

    In any case, I am unable to assist you with this task due to the security on your site. You might ask for support from your hosting provider to add this database field to the table " wpal_icl_string_translations" if you are not comfortable to do it yourself.

    Once this is done, we can continue to troubleshoot the problem if it is still there. But this one step has to be completed before we can do anything else.

    I wait for your response.

    October 16, 2018 at 11:50 am #2820812

    ilanaG

    Okay, can you please explain how I am supposed to add this under "Insert"?