This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by florianM-26 3 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
June 17, 2019 at 12:49 pm #4035343

florianM-26

Link to a page where the issue can be seen: hidden link

I expected to see: a Site in German

Instead, I got: a site in English

June 17, 2019 at 1:06 pm #4035417

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have visited this link hidden link and site showing in German language as you can see in the attached screenshot. Could you please clear your browser cache and take another look on it.

Thank you

June 18, 2019 at 8:25 am #4041315

florianM-26

Hi Noman,

as you can see in the "Search" bar and down in the comments of an article, the whole menu and everything I haven't set up myself is still in English (see attached screenshot), that's my problem.

June 19, 2019 at 5:19 am #4048009

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please follow the below steps and let me know how it goes?

- Please rescan the active theme in WPML >> Theme and plugins localization section

-Then go to WPML >> String translation >> Search for the string/word you want to translate >> Add a translation >> Check "Translation is complete” >> Save.

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

June 19, 2019 at 12:41 pm #4051543

florianM-26

Hi Noman,

the site already was in German and worked properly for the last 8 months with WPML. Now both sites (German and English) are in English.

Best regards

June 19, 2019 at 1:22 pm #4051795

martinB-74

Yeah, we have the exact same issue after updating to the latest WPML version a couple of days ago.

So either the latest WPML Multilingual CMS Update (4.2.7.1) or the WPML String Translation Update (2.10.5.1) broke the string translations.

June 19, 2019 at 6:06 pm #4053795

florianM-26

@martinb-74 at least I'm not the only one. I think the problem started at our site when we updated the String Translation.

June 20, 2019 at 5:41 pm #4062133

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

July 4, 2019 at 1:08 pm #4143659

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for login details. I have fixed this issue by selecting ‘Themes and Plugins mit WPML String Translation übersetzen und immer .mo-Dateien als Backup laden’ option from WPML >> Lokalisierungsoptionen >> Plugin-Lokalisierung as you can see in the attached screenshot.

Could you please check and confirm?

Thank you

July 4, 2019 at 1:12 pm #4143711

florianM-26

This worked well. Thanks for the quick responses and solution!