This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 1 year ago.

Assigned support staff: Bigul.

Author Posts
September 23, 2018 at 5:56 pm #2758892

yaserk

Hi,
I had trasnferred my site from previous server to new on (siteground). But now the arabic version is showing error

( 404 - Not Found
The page you are trying to access does not exist.
If this error persists, please contact the website webmaster.)

Please check what is the issue.

Regards
Sumesh

September 25, 2018 at 9:14 am #2763151

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Sumesh,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please visit WPML>>Languages>>Language URL format and check you are getting a warning message like this - hidden link

Also, please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

September 25, 2018 at 9:06 pm #2765259

yaserk

Hi,

Thank you for your reply.and yes I am getting the same warning message in WPML>>Languages>>Language URL format ( please see the attacehment)

Also please find the below WordPress debug.log link

https://pastebin.com/iRVqzBJd

Looking forward to hear from you soon.

Regards
Sumesh

September 26, 2018 at 7:12 am #2766095

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Sumesh,

Thank you for the feedback. The *debug.log* file is not showing warning or notice related to WPML. So it looks like a compatibility conflict. Please let me know the following for tracking the issue.

1) Please check you are using any special code in .htaccess file

2) Please check you are getting any error in Server Error log file related to this(may you have to contact your hosting provider for getting this data)

3) Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

The topic ‘[Closed] Site not translating -showing error’ is closed to new replies.