No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 3 replies, has 4 voices.

Last updated by Raja Mohammed 3 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 10, 2019 at 12:00 pm #4179827

Jamie Coleman

We had our site installed in English but all pages and posts are in Spanish.

So to fully translate our site we have changed WP default language to Spanish then installed WPML and committed the steps and added language selector in footer but the site doesn't get translated to other languages.

We want our site in Spanish mainly with English translation and we couldn't get it to translate the site to Spanish.

Here is a screenshot of the language selector and it doesn't show English, tried typing the translation URLs manually and didn't work.

Site is mackech.com closed to the public at the moment but we can provide login credentials.

July 10, 2019 at 10:45 pm #4184673

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

In regards to your request we will need to involve the Developer which has received an invitation to join this thread.

I will be in contact as soon we received feedback.

Kind regards
Andreas

July 13, 2019 at 5:52 am #4202961

lisaN-4

Any update?

July 15, 2019 at 3:33 am #4206783

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Kindly Apologies for the delay, I have taken over this ticket from Andreas due to timezone difference.

Welcome, @lisan-4
Moving forward, The languages in language switcher will not be visible if the page is not translated or hidden from the WPML settings.

1) Please make sure the pages are translated, Please refer to the instruction if you are unsure how to translate the contents in your site https://wpml.org/documentation/getting-started-guide/#translating-without-wpmls-translation-management

2) Make sure the language is not hidden in the settings => WPML > Languages > Hide languages

If you are still stuck and need further assistance, Kindly share temporary access to your site, I have enabled private fields for you to securely share the details.

Kind regards
Raja

The topic ‘[Closed] Site not translating, Wmpl not working’ is closed to new replies.