This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bruno Kos 5 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
April 24, 2019 at 8:44 am #3670477

gwendolaP

Tell us what you are trying to do?
I have updated everything to the latest versions, en sice i got serious perfomance issues. we cannot open our product pages and users complain they cannot login to their accounts. if i disable the woocommerce multilangual plugin, the performance is lots better.

Is there any documentation that you are following?
i tried all your setting advices but with no results

Is there a similar example that we can see?

What is the link to your site?
hidden link

April 24, 2019 at 1:09 pm #3673289

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you please check this errata and try what has been suggested there?
https://wpml.org/errata/timeouts-with-woocommerce-multilingual-4-6-1/

If this works for you, let me know. This patch will end up officially in WCML 4.6.2.

Another thing - could you make sure your server conforms to our minimum requirements?
https://wpml.org/home/minimum-requirements/

Based on provided debug information, I can see the following - WP Memory Limit: 40M.

Specifically, could you set WP Memory limit to at least 256MB?
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

If unsure on how to set this, you can consult your host/server admin to do this. After you increase this value, you can confirm it by checking on WPML -> Support by finding the “Memory limit” value.

Regards,
Bruno Kos

April 24, 2019 at 1:28 pm #3673415

gwendolaP

I have changed the memory settings in .htacces an wpconfig to 512mb

i tried your patch but with no results.. opening the product page on the backend takes ages.

My biggest problem is that i need this plugin.. and at the current state i cannot open the site for my customers 🙁

April 24, 2019 at 4:23 pm #3675127

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can I ask you the following then? In order to debug this issue , can you install Duplicator plugin and create package so that I can try this on my localhost and possibly escalate further to 2nd tier?

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

If yes, I will need WordPress admin username and password so I could download those packages. I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

Regards,
Bruno Kos

April 25, 2019 at 9:04 am #3680351

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I am not sure how to log in to any of these credentials - I get 404 not found when trying to enter hidden link, while as for FTP, is the url put there actually a password or? Because this isn't working for me either.

Regards,
Bruno Kos

April 25, 2019 at 1:48 pm #3683049

gwendolaP

I will give you this information and the duplicator packet later today, I decided to restore the backups of 18-4-2019 cause i could not hold the webshop unavailable for our customers any longer. for now it works without the latest updates.

April 25, 2019 at 1:50 pm #3683057

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It seems like that this WooCommerce Multilingual performance issue fix is going in 4.6.2. version which should be published hopefully soon, perhaps in few days at most.

Can you wait on this thread until that happens, update the plugin and tell me if it fixed your site issues?

Regards,
Bruno Kos