This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.96 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 2 voices.

Last updated by Riffaz 8 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
January 27, 2019 at 2:17 pm #3132783

kaan

Hello,

I checked previous tickets and found site title in string translations. I translated them but changing blogtitle from string translations didn't update blog title.

After that I edited blog title from stings translation again and now things are weird.

In wp general settings blog title is: aaaa ( cant change it from general settings page anymore when i change and click save it turns back to aaa)

In string translations blog title is BBB for first lang and CCC for second lang. When I load site it shows aaa in every language as the title.

Also when I search for aaa in string translation nothing is found.

January 27, 2019 at 2:55 pm #3132809

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Just select domain WP in WPML > String translation : hidden link and click on search.
See if you can see the tag line now.

Let me know the results, please.

Regards,
Riffaz.

January 27, 2019 at 5:45 pm #3133092

kaan

I already checked that and have already translations for the title. However in the frontend when changing titles it doesn't work. Site title shows only in one language. When I go to strings I see both translations. Also edited severl times but no luck.

January 28, 2019 at 5:57 am #3133917

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

When I go to hidden link the title is : hidden link
When I go to hidden link the title is : hidden link

So your site shows the translated titles very fine.
Are you asking about something else?
If yes, show me a screenshot for better understanding.
If no, hard clear your browser cache and check.
Check the site in incognito mode.

Regards,
Riffaz.

January 28, 2019 at 5:13 pm #3136864

kaan

This title on homepage is written with yoast seo plugin not the site title we set. Thats why it translates.

Check :

hidden link
hidden link

Page title changes but site title remains same.

About Us | ""THIS PART REMAINS SAME""

January 29, 2019 at 6:03 am #3138322

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

This is normal and expected
When you use YOAST, site title you set will be overridden by the YOAST setting.
You can simply google it or check YOAST doc.

Regards,

January 29, 2019 at 2:54 pm #3140299

kaan

When yoast is disabled it still has this problem.

What I mean is I use my own title for homepage with yoast so you didn't see this error on homepage but for regular pages site title is same for all languages even if yoast is disabled.

There is a problem for sure..

January 30, 2019 at 7:02 am #3142400

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am setting the next reply as private.
Let me know your site login details to check this closely.

Regards,

January 31, 2019 at 9:34 am #3146968

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I do not see WPML on your site: hidden link
Are you not using it anymore?

Regards,

February 4, 2019 at 2:41 pm #3158151

kaan

did you check?

Can you hide the site name in my previous post please.

February 5, 2019 at 6:12 pm #3163301

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I moved your reply site link to private.

Sorry for the delay.
I've been checking this with the team.

Site title will be used from Setting > general , only if you do not use YOAST.
When you install YOAST this will be replaced by the YOAST.
In that case, you have to set it in YOAST. Please check their doc.

To make this sure, just disable the YOAST.
You will see the translated site title in your pages.
When you re-enable YOAST you will see the site title from YOAST.

So in summary if you use YOAST you have ti set it in the YOAST.
If you do not YOAST the site translation (with WP domain) will work fine.
So this sepends on how YOAST altering it.

Regards,

February 5, 2019 at 7:34 pm #3163537

kaan

Let me sum up the situation because issue goes on even if yoast is not active. I even uninstalled and tried it like that.

--- 1st of all if you disable yoast, wpml still behaves like that.

--- Secondly I ask you to check about us page title in both languages. You check homepage only. Even if yoast isn't active titles still doesn't translate.

Please turn off yoast and go to about us page and look at the both titles yourself.

February 6, 2019 at 4:03 pm #3166478

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

you are right.
This is unusual.

I could not reproduce this issue in my localhost with a default theme.

So we have to check this with your theme.
Please:
1. go to hidden link
2. install the theme and configure
3. configure the WPML as you have in your site. at the last step (sitekey) just click next.
4. recreate the issue.
5. no need to create many posts and pages. Just one post and one page is enough.

Let me know.

Regards,

The topic ‘[Closed] Site Title Translatio Problem’ is closed to new replies.