This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by h.w.a.e.K 1 month, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 8, 2020 at 10:05 am #5864777

h.w.a.e.K

I am translating using WPML from default Dutch to English. When switching to English the entire site width changes and is no longer full width. I'm using Elementor Pro as a page builder and the theme is Phlox.

What is the link to your site?
hidden link (site is currently set on private, you'll need login credentials.)

April 8, 2020 at 11:46 am #5865543

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 9, 2020 at 3:53 pm #5877603

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

FTP won't be needed for the moment.

However, I am not able to access the site at the moment using the credentials that you shared.

Can you please check?

I'm also attaching a screenshot below.

Kind regards,
Mihai

April 10, 2020 at 7:29 am #5881597

h.w.a.e.K

I provided you with a temporary login link instead. See private message. You won't need a password.

April 10, 2020 at 10:33 am #5883167

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for sharing the credentials.

From what I was able to find out, it seems that there is some specific CSS that's applied to the initial homepage (I'm attaching a screenshot of it) but that's not targeting the translated content.

I went to Appearance > Customize > Custom CSS and I added this CSS:

/* WPML edit - make sure website is served in full width */

.aux-container {
    max-width: none !important;
    padding-left: 0 !important;
    padding-right: 0 !important;
}

The issue is now resolved.

Can you please confirm?

Kind regards,
Mihai

April 10, 2020 at 10:45 am #5883211

h.w.a.e.K

My issue is resolved now. Thank you!