This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by gerardM-3 2 months ago.

Assigned support staff: Diego Pereira.

Author Posts
August 15, 2019 at 11:28 am #4400479

gerardM-3

Hello !

I would like to reduce the size of the icl_string_pages because of the 600000 records.
My site have less than 100 pages in 2 linguages
I'm using the new beta versions, and I have not the Recreate ST DB cache tables button.
What can I do ?

August 15, 2019 at 2:40 pm #4401693

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @gerardm-3, welcome to the WPML support Forum!

Please try the following:
- Rename the sitepress-multilingual-cms folder (on wp-content/plugins)
- Download the previous version of WPML here: https://wpml.org/download/wpml-multilingual-cms/?section=changelog
- Install on your website and run the "Recreate ST DB cache tables" option (on WPML > Support > Troubleshooting)
- after that, update WPML and WPML String Translator to the beta version

Please let me know if it worked for you.

All the best,
Diego

August 15, 2019 at 5:15 pm #4402589

gerardM-3

Thank you for your fast reply.
When I had renamed the folder of cms the site had a fatal error.
So I disabled and uninstalled the plugins cms-strings-management beta versions in WP and reinstalled earlier versions.
This time it was ok and I was able to recreate the database and solve my problem. Now I have 29000 lines.
Thank you