This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by oliverF-6 2 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 16, 2019 at 1:13 pm #4220277

oliverF-6

That is also my problem: https://wpml.org/forums/topic/language-switcher-does-not-skip-untranslated-posts/
But I cant find the option in the Translation management...

July 16, 2019 at 1:19 pm #4220361

oliverF-6

found it, under settings... looks like set correctly

July 16, 2019 at 7:05 pm #4223427

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. In order to hide the language switcher flag/menu for your translated contents you should set your 'How to handle languages without translation' option to 'Skip language' from your WordPress Dashboard > WPML > Languages > Language switcher options settings. See: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Please, let me know if it helps or if you need any additional details and clarifications. Have a nice day.

July 17, 2019 at 7:14 am #4226465

oliverF-6

this is set correctly...

July 17, 2019 at 7:17 am #4226525

oliverF-6

for untranslated content I would expect that the EN Flag is not visible in the language switcher.. but this does not work

July 17, 2019 at 10:01 am #4228429

oliverF-6

Just checked it again and saved the settings. Equal which setting, switching to english for untranslated pages brings me to the homepage...

July 17, 2019 at 1:54 pm #4230861

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 19, 2019 at 6:17 pm #4247831

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and noticed your theme uses a custom language switcher, also there's some kind of theme cache which might be the reason of your issue, in order to confirm it, please, try the following:

1 - In your WordPress Dashboard > WPML > Languages click to setup a footer language switcher for your website and try your website frontend if the language switcher is hiding the language for untraslated content as it should.

2 - If not, change to a default theme and try it with a default WPML language switcher.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

See: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Please, let me know if it helps. Have a nice day.

July 22, 2019 at 9:34 am #4255495

oliverF-6

My issue is resolved now. Thank you!