If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 3 voices.

Last updated by Marcel 2 months ago.

Assigned support staff: Marcel.

Author Posts
August 28, 2019 at 1:53 pm #4474873

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please see my previous private reply and let me know once the migrations has been completed. Thanks!

September 3, 2019 at 2:48 pm #4505571

Bjoern

Hi Lauren, Sorry to bother you again, I had a few days off. Hope you are fine. I have checked the theme options and typography, but somehow I get different fonts on each slider and I am not sure why. The options are the same on all three pages. Could you give me another tip?

September 4, 2019 at 4:58 pm #4513043

Bjoern

Hi Lauren, I solved that typography problem. Can you help me to check the language switcher again? Its still not working. Thanks a lot.

September 5, 2019 at 9:40 am #4517911

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Bjoern,

my name is Marcel and I'm taking over this ticket because Lauren is not available today.

I checked your site and can reproduce the issue switching for example, from hidden link to Spanish.

For further debugging I would like to test this on our Cloudways Server. Could you please migrate your website to Cloudways credentials Lauren shared with you? Here I will run the site in a minimal environment and run a PHP debugging.

Thanks
Best Marcel

September 6, 2019 at 9:27 am #4524371

Bjoern

Hi Marcel,

I did the migration. Thanks for your help man!

Really appreciate it.

September 9, 2019 at 1:26 pm #4537611

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Bjoern,

The language switcher on your Top Bar always stays empty. It doesn't get any connection to a page. May you know where did you assign it?

If you create a new menu switcher under WPML -> Languages it's working:

Please see hidden link

Please let me know.
Best Marcel

September 10, 2019 at 8:14 am #4542865

Bjoern

Hi Marcel,

Thanks for trying to help me, but the language switcher does not work at all. Why did you send me again the link? Did you read the threat?

The link you sent me was the first thing I tried, also together with Lauren. Why did you send it to me again? I am bit confused.

I am not sure if you understood my problem here? The normal language switcher does not work at all on my site. I did a work around by myself (creating flags and links and place them in the top header under social links), just to be able to link to the different languages of my sites. This is however a temporary solution.

PLEASE let me know what is the solution here, i am getting a bit tired of writing so many emails and not moving forward with the problem. If you cannot solve it , could you be so nice and refer me to somebody more senior?

Sorry man, it is not personal, but I would appreciate somebody who really can help me on this issue.

September 10, 2019 at 4:55 pm #4547533

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Bjoern,

the provided link was not posted during your chat with Lauren, nor in the ticket process, so I don't fully understand what you mean?

<l>
Thanks for trying to help me, but the language switcher does not work at all.
</l>
Yes, because no translation status get assigned to your language switcher. I read you copied the individual language domain hidden link in the header manually as a workaround to your header. This will not work, as this is missing additional code to create an AJAX call.

I don't find where you added first the language switcher as shortcode what you wrote in the chat or what caused the problem using this way.

Anyway, the correct way is this:

#1 Please create a new languages switcher as described in my link
#2 Add it to your PHP using this way: https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

Here is a working example using a language switcher on the Main Menu hidden link

So, #2 means you need to hook this working language switcher into the correct theme position on your Avada top header.

This will solve your issue.

Best Marcel

September 13, 2019 at 3:05 pm #4569751

Bjoern

hi marcel,

thanks a lot for the clarification. i am a novice with php scripts. not sure where exactly i need to copy the code within the avada theme. could you specify please? sorry to bother you man. for me its complicated. for now i added the switcher in the menu.

thanks

September 13, 2019 at 3:09 pm #4569769

Bjoern

sorry again marcel,

actually i would like to place the flags not next to the menu, but in the top position (where i placed the flags for my work around). isnt there a short code, which i can just place there?

thanks, i really appreciate your patience.

September 13, 2019 at 3:16 pm #4569783

Bjoern

hi marcel,

just to clarify:

1. my client wants the flags in the top header, exactly where i placed my workaround. how do i accomplish that?

2. could you tell me where to place the code within avada.

3. if i pay for it, could you do it?

again, ia m a novice in php and chose wpml because i thought it works with short codes.

thansk for your help and sorry to bother you.

September 13, 2019 at 3:37 pm #4569861

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Bjoern,

you can try the following:

Try to search the class "home" in your header.php File and try to add the language switcher using this way:

<?php do_action('wpml_add_language_selector'); ?>

You can use your Browser DevTools to find the correct position, for example for a better orientation search for the contact icons which will be in the class "fusion-social-links-header".

We self as don't provide custom code solution, but we have a great network of certified WPML developers which you can contract to change this for you. More information you will find here: https://wpml.org/contractors/

Best Marcel

September 13, 2019 at 4:05 pm #4569989

Bjoern

hi marcel,

sorry to bother again. i am really desperate now. how much do you charge me to place the widget or code in the right place? i really like the translation management of the plugin, but i am unable to place the it where i need to have it. i give up. please let me know how much it takes to help me. i copied a short code [wpml_language_selector_widget] in the theme header under theme options/header styling i am sure that is not correct, but i am unable to place it properly.

thanks.

September 13, 2019 at 4:16 pm #4570017

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Bjoern,

please change it directly in the header.php File.

Our support policy doesn't allow custom code solutions, so we can't provide you with a free or paid solution. Please reach a certified WPML contractor on the submitted link to get an offer for this change.

Best Marcel

September 13, 2019 at 4:50 pm #4570185

Bjoern

Hi Marcel,

thanks a lot.

Should I create first a child theme before copying the custom wpml code?

Thanks again.