This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Raja Mohammed 5 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 8, 2019 at 7:32 am

davidF-18

I am trying to: Add Arabic to existing site

Link to a page where the issue can be seen: hidden link

I expected to see: Slider working

Instead, I got: Slider loads first image, then all subsequent images are blank until first image repeats. Slider L/R Nav buttons are misaligned.

May 8, 2019 at 11:47 am #3766219

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have checked your site. It seems more like an issue with the slider not compatible with RTL language than the issue with WPML. I'm not sure about the location from where the slides are added, could you please help me with that. Maybe I can get some clue there.

Kind regards
Raja

May 8, 2019 at 11:56 am #3766341

davidF-18

Hi Raja,

Thanks for your help.

The slides are added from a box on each page below the text input area - the box is called Large Slider/Gallery.

David

May 8, 2019 at 12:51 pm #3766753

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the clarification. The theme seems like a custom built, Please confirm with the developer whether the slider is RTL compatible, This is more likely the RTL styles are not applied properly.

Backup your site and database, Before proceeding with next step

To confirm the issue temporarily disable the WPML plugin for the time being this won't cause any data loss, add the below code to wp-config.php, Access the site home page does it display any the slider properly? Let me know the results.

define( 'WPLANG', 'ar' );

Once you have observed the results, Remove the code from wp-config.php and reactivate wpml

Kind regards
Raja

May 8, 2019 at 2:24 pm #3767719

davidF-18

Hi Raja,

Thanks - I tried the steps you suggested, with WPML deactivated and the code added to WP-Config, the slider works fine.

David

May 9, 2019 at 10:39 am #3775267

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the information, Seems this needs to be debugged, Please provide a snapshot copy of your site, You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

Kind regards
Raja

May 9, 2019 at 12:44 pm
May 10, 2019 at 10:31 am #3783315

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi David,

Thanks for the backup file.

I can confirm the issues is not related to WPML rather the slider is not RTL compatible.

To confirm this follow the below steps
- disabled WPML,
- Change the site language to Arabic from Settings > General

This will make sure the site is loaded in RTL language without WPML. The slider in the home page is broken since the RTL style is applied to the site.

Please refer to screencast explaining the steps: hidden link

Please check with your theme support they can help you fix this issue.

Kind regards
Raja