Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 3 voices.

Last updated by Marcos Vinicios Barreto 2 weeks, 5 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
November 16, 2019 at 1:18 am


Dear Support,

I set new Revolution Slider. and make it multi-language. I 've done this before, but now, my translation slide not showing on my translated site

Am I doing it wrong?
Please check

November 18, 2019 at 2:49 pm #4966029

Diego Pereira

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

This is our guide on how to translate Revolution Slider with WPML:

Could you please confirm that you followed all the steps in this guide?

Please let us know if it worked for you.

November 19, 2019 at 3:38 am #4968357


Yes, I 've done this before.

but last update WPML, then my translation rev slider is gone. can you please check

November 19, 2019 at 6:35 pm #4975143

Marcos Vinicios Barreto

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)


Thank you for the updates. I tried to access your website to give a detailed look in your WordPress Dashboard settings, but unfortunately the provided access details don't seem to be correct. I will enable a private reply for you, so, you can safely resend them, in any case, please, try the following:

1 - Click to edit the homepage in the default language from your WordPress Dashboard > Pages settings.

2 - Change to your secondary language where the slider are not appearing and make sure there's any Revolution Slider shortcode assigned for the translated homepage, in most cases the shortcode is entered in the page options most themes offer.

Please, let me know if it helps, have a nice day.

November 20, 2019 at 12:16 am
November 20, 2019 at 9:12 pm #4984333

Marcos Vinicios Barreto

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)


Thank you for the provided details. I took a detailed look in your slider settings and indeed there's no slides in the indonesian language and this is why the slider is hidden in the secondary language.

I recommend you to follow the steps at: and a add your translated slides again, as you have just one slider added then it should be a simple step.

I would recommend you to recover a backup copy of your website if you had a lot of sliders published to avoid any tedious work of a manual intervention, fortunately not needed in your case.

We will be investigating this issue if we got some more reports about this issue. Thank you for your understanding, have a nice day.