This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Riffaz 1 year, 3 months ago.

Assigned support staff: Riffaz.

Author Posts
March 24, 2019 at 7:28 pm

alessandraV-3

I am trying to: make the website work as before where the slider visible in English was appearing in other languages. THe media translator plugin duplicated several media files, and is blocking now everything.

Link to a page where the issue can be seen: hidden link hidden link slider sections

I expected to see: hidden link slider works ok

Instead, I got: error visible

March 25, 2019 at 4:36 am #3449631

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Are you asking about this slider? hidden link

THe media translator plugin duplicated several media files, and is blocking now everything.
- if you disable the WPML media, do you get the slider back and it works again?

Are you able to create separate sliders for each language and then able to select a slider according to the language?
Does you theme allow this?

Let me know after checking these if you can short this out.
If not, we may have to check your theme in a fresh installation.

Let me know how it goes.

Regards,
Riffaz.

March 26, 2019 at 7:47 am #3459803

alessandraV-3

Hi,

Yes, I did deactivate the WPML plugin, but that didn't help.
The theme perfectly allows to do create sliders with different names. That was how it used to be, but since I updated the WPML plugin, the issue started.

You already have the access information. Please help me fix the issue.
Thanks

March 27, 2019 at 10:04 am #3469321

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I see 500 error when I go to other languages site except the English site : hidden link

Did this not happen when you create the ticket? or something happened recently ?

Did you try selecting corresponding slider (hidden link) when you are in The One Pager > Settings > Featured Slider : hidden link ?

Let me know.

Ps:
I did not change anything yet in your site.
Since it's a live site I do not want to do anything before you confirm everything. 🙂

Regards,

March 29, 2019 at 9:53 am #3489961

alessandraV-3

Hi, the 500 error has been solved, but now only 1 slider appears in all languages. Can you please solve it? Thanks.

March 29, 2019 at 12:43 pm #3491309

alessandraV-3

Thank you for taking care of this.

The web now is back online, no more error 500 in other languages (there was an issue with the http/https redirections)

Today, some sliders appear but we do not understand why these do and the others don't.

Notice that everything is configured to work as in the $nglish version, but probably the media translation is blocking the feature images to appear?

If you go to WPML media translations, we have a duplication of all the images now. If you go to media of wordpress, only few images appear.

Could you please help?

Regards.

March 31, 2019 at 12:28 pm #3501953

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the update.

Today, some sliders appear but we do not understand why these do and the others don't.
- may be because of you selected Spanish version of slider in english: hidden link
- anyhow, I've changed it to english slide.
- now you can see all the slides in english but it does not work in other languages

the 500 error has been solved
- if I change to German slider I still see 500 error.

probably the media translation is blocking the feature images to appear?
- nop
- I checked this by deactivating your WPML media plugin.
- I still see the same issue.

NOTE:
+ Before trying anything make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Possible reasons:
1. Third party plugins.
- please disable all the plugins and check.

2. Out dated WPML
- I see you are using older version of WPML and it's AddOns
- please update WPML and it's addons
- disable other plugins and check.

3. You/we are translating it incorrectly
- please contact your theme support and ask abut translating the Featured Slider.
- there might changed something in latest updates

Even if you see the same issue after trying all these please enable the WP Debug mode and check if you see any errors when you visit to the other language.
Please follow the steps and let me know the errors if you are getting:

Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

April 1, 2019 at 6:17 am #3504065

alessandraV-3

Thanks for your detailed answer. I see that we are back in the first description of the issue, where slides in other langauges do not appear and an error is visible for the public.

In my previus message, we were seeing some slides but not translated. I really do not understand what is happening. Theme and wordpress version were working fine.

Could you please help me deactivate the slides in other languages? so at least users do not see errors?

Thank you.

April 1, 2019 at 1:06 pm #3508311

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

For now, I hid the slider in other languages using this code : hidden link

Still we can fix this if you test as I explained here: https://wpml.org/forums/topic/slides-are-not-appearing-in-other-languages-but-englishs/#post-3501953

I highly recommend you to show the screenshot hidden link and the reply https://wpml.org/forums/topic/slides-are-not-appearing-in-other-languages-but-englishs/#post-3501953 to your theme support and the get back to us if you want to fix this.

Regards,

The topic ‘[Closed] slides are not appearing in other languages but englishs’ is closed to new replies.