This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 3 voices.

Last updated by toshi 1 year, 5 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
May 11, 2018 at 3:38 pm #2090815

toshi

I am trying to:

make my slideshow contents work in non default language. It had always been consistently showing this slideshow in both language over the last 7 years... Now only default language outputs it after updating WPML to the latest version.

My code is below

                    <?php 
					$query = new WP_Query();
					$query->query('tag=slider&posts_per_page=8&post_type=any');
					if ($query->have_posts()) : while ($query->have_posts()) : $query->the_post(); ?>
                    <?php if (  (function_exists('has_post_thumbnail')) && (has_post_thumbnail())  ) : /* if post has post thumbnail */ ?>
                    <div class="slides_container">
                        <a href="<?php the_permalink(); ?>"><?php the_post_thumbnail('slider-full'); ?></a>
                    </div>
                    <?php endif; ?>
                    <div class="slides-nav">
                        <a href="#" class="prev">Previous Slide</a>
                        <a href="#" class="next">Next Slide</a>
                    </div>      
                    <?php endwhile; endif; ?>
               		<?php wp_reset_query(); ?>

Please help.

May 11, 2018 at 3:47 pm #2090949

toshi

I said only default language outputs the slideshow. This means when the site is non default language there is no slideshow html tag is output which meant to be generated by using the code above. The code outputs nothing.

May 13, 2018 at 12:14 am #2103119

toshi

I am wondering what has changed to make the slideshow disappear in other language. It's been always displayed in all language before WPML 3.9.4.

May 13, 2018 at 5:46 pm #2107751

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thank you for contacting the WPML support forum.

Are you referring to the slider at the top of the homepage of your site in English?
Please see attached screenshot.

Thanks,
Itamar.

May 13, 2018 at 10:44 pm #2109870

toshi

Yes that's right but could you please take that image out in this thread. The reason why I did not include the URL is because I didn't want people to see it.

May 14, 2018 at 5:46 am #2110933

toshi

Please take the screenshot off this thread as soon as possible... And block this and previous comment about it as well.

May 14, 2018 at 6:37 am #2111174

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

To your request, I've removed the screenshot.

Could you go please to WP Memory Limit -> Languages -> Language filtering for AJAX operations and check if the 'Store a language cookie to support language filtering for AJAX' is checked or not?
If it is not checked could you check it please and save the settings and then check if the problem persists?

Thanks,
Itamar.

May 14, 2018 at 6:41 am #2111265

toshi

Where does the "WP Memory Limit" located?

May 14, 2018 at 7:26 am #2111726

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

I'm sorry but I do not understand what do you mean when you ask: "Where does the "WP Memory Limit" located?" And also how is it related to the issue of this ticket.
Could you elaborate, please?

May 14, 2018 at 7:57 am #2112479

toshi

Sorry about bad English. Where is the "WP Memory Limit" located? is the correct one. Where can I find WP Memory limit. Is that in the WordPress control panel?

You said "Could you go please to WP Memory Limit -> Languages -> Language filtering"
Unless I understand the location of WP Memory limit, it is difficult for me to do what you suggested.

Regarding your message "how is it related to this topic" I also do not understand your reason behind such question.

May 14, 2018 at 8:11 am #2112623

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

You can try to increase the "WP Memory Limit" in the following way.

You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

If it does not increase the "WP Memory Limit" to your WordPress installation, you might need to ask the hosting service of your site to do it for you.

I hope that this will help you.

May 14, 2018 at 8:56 am #2113416

toshi

Ok I did add two lines you have provided. The WP memory was 125. Also I've checked the language filtering option (WPML > Languages) and refresh the caching. But nothing has changed...

May 14, 2018 at 3:58 pm #2124219

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

I'm consulting our second tier supporter about your code and the issue.
I'll reply here when I have an answer from him.

Thanks,
Itamar.

May 14, 2018 at 4:04 pm #2124281

toshi

Thank you. I am looking forward..

May 15, 2018 at 9:20 am #2133398

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

My superiors have asked me to escalate this issue.
Could you please share with me a Duplicator package of your site or let me have access to your site's admin, and I'll make a copy of your site?
Also please explain to me how this slider is implemented?
Is it a plugin?
Where in the files of your site I can see the code that you have sent me?

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved, I will delete the local site. Let me know if this is ok with you.
** IMPORTANT **
- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields, this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Thanks,
Itamar.