This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by Shekhar Bhandari 3 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 3, 2019 at 4:35 pm

bentJ

I am trying to Increate page load speeds

Link to a page where the issue can be seen: autoconnectgps.com is under construction. I created a clone of the website under ensuretrackgps.ca

I expected to see: less Slow Queries and 1-2 second add to cart etc. actions instead of 5-10

Instead, I got: High load times and wc action times (add to cart, remove from cart, quick view etc.)

THe website is a very heavy one and we are aware of it (wpml+woocommerce+elementor etc)
To overcome this, we have tried MANY MANY caching setups and finally ended up in a very aggressive but fast cache system in place.

The only problem happens when we are doing actions that cannot be cached in such an aggressive way (currently opcode and Memcached is also active) like adding something to cart. It takes up to 5 - 10 seconds.

Especially on the back end, query monitor shows slow queries and its almost exclusively wpml originated.

While I am aware a level of slow down is expected, I'd really appreciate if you could help me out with figuring out this extreme slow action times.

Thank you VERY much and I hope you have a wonderful week.

PS: I cloned the website to a new location in case you needed to test: dev.autoconenctgps.com

June 4, 2019 at 3:55 am #3947765

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

I just visited the site and noticed that you have all strings auto-register, disabling this can help to increase the performance, can you please review the following articles and see if all the relevant steps are covered?
https://wpml.org/faq/prevent-performance-issues-with-wpml/
https://wpml.org/2012/01/can-your-site-run-faster/

Further, try disabling and re-enabling all WPML plugins and then going to WPML > Support > Troubleshooting and press the "Recreate ST cache tables" button.

The first visit after the re-activation of the plugins is kinda slow, but after the regeneration of the tables - it will be better.

Look forward to your reply.

Thanks

June 4, 2019 at 3:33 pm #3953353

bentJ

Hello Shekhar,

Thank you for your reply. You said to turn off auto registration of all strings but I already ran through these links yous ent me, before i opened this ticket, and the first link tells me to make sure all text domains are auto registered, instead of your remove auto registration idea. Just want to amke sure there is no confusion.I should remove all checkboxes from that edit list?

June 4, 2019 at 3:59 pm #3953559

bentJ

I turned off auto register for all text domains, disabled all wpml plugins, cleared cache, reactivated the plugins and regenerated ST tables.

I have not seen any increase of change in the speed in any direction.

At some inner pages I still get over 2500 queries with WPML on while 250 when it's off.

I could really sue your help on this. Thansk in advance, Umut

June 5, 2019 at 3:40 am #3956971

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the details.

Regarding the auto-register strings, I am trying to get more confirmation from the team and will respond back to you here.

Further, could you please provide feedback on the following questions as much as possible?

#1
What type of hosting do you have? Shared, VPS, Dedicated, etc?

#2
Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

#3
Could you please perform the below steps and share me the results?

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Thank you for helping us pinpoint the issue. Feel free to add any further information you may have.

Look forward to your reply.

Thanks

June 5, 2019 at 3:01 pm #3962045

bentJ

Hello Shekhar,

#1
We have a dedicated resource GoDaddy business account with ONLY this website in it:
90 GB storage, 4 GB RAM, 2 CPUs. All software is up to date and all WP resources are set to high. I'm running other E-commerce websites in hostings WAY lower than this without this level of issues.

#2
I ran this test: Default theme + ONLY Wpml and Woocommerce active. I still get slow queries from WPML, especially with woocomerce actions. (please see attachments) These slow retrieve times multiply when the other plugins and theme are on and generally there are 4-5 queries like this that take up to 3 seconds of the total load time. And this is on the original content language not a translated one.

This set up is a heavy one with elementor and woocommerce. Those definitely affect page speed but WPML has an amplified effect when everything is on. QUery Monitor consistently alerts for at least 2-3 slow queries from WPML every page load.

#3
I recently cleaned all errors in the debug file. Today I cloned the website again (hidden link) and started interacting with the website to generate a debug file. The only lines generated were:

[05-Jun-2019 14:52:04 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/in7obza5wlhd/public_html/autoconnectgps/wp-cron.php on line 111

I also uploaded two more screenshots of a heavily slow page action results in displaying slow queries. (first one default language, latter one is translated content)The only issue I cannot mitigate with caching etc is the time it takes to:
1- Add toc art
2- Update cart
3- Checkout
4- Load pages with elementor templates

June 6, 2019 at 2:57 am
June 10, 2019 at 10:31 pm #3990675

bentJ

Hello Shekhar,

I missed this response so forgive me for the late reply.

I migrated as instructed (PS: it did not ask for DB user and password)

I also can create for you a clone of the website so you can test on our server environment too if you wish to.

Thanks in advance,

June 11, 2019 at 12:17 pm #3994975

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the info.

I am debugging this issue and will respond to you soon.

Thanks

June 11, 2019 at 12:53 pm #3995311

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The login details for the site is similar to your site, so can you please log in once and see if you can see improvements, I deactivated most of the plugins and the site is running without any issues.

Look forward to your reply.

Thanks

June 11, 2019 at 2:40 pm #3996307

bentJ

Hello again,

I am having trouble understanding the response. Ofcourse if you deactivate all plugins site runs faster. But WP doesnt work like that does it. It requires plugins and optimization, which is why Im reaching out to you.

Deactivating other plugins and showing me site speeds up does not prove that wpml was not the problem. It only means WPML alongside other plugins is creating issues and is not working in tandem with the rest. Let me introduce to you:

Just like you did, I created a clone of the original website, turned off caching, tested the website speed(on the left), then turned off wpml plugins and rerun the test(on the right). You can see in the screenshot with wpml deactivated but still everything else is on (43 active plugins) the website speeds up twice.

This difference is even bigger on the back end, unfortnately I cant test and show like this. So with your logic does this mean WPML was the issue or the other 43 plugins that actually work in tandem and when I cache its very acceptable, until I activate wpml. Also when WPML is active alongside everything else, WPML is the only plugin that pops p slow query alerts, up to 5-6 of them in a single page load.

Look forward to your reply.

Thanks

June 12, 2019 at 10:56 am #4003235

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the information.

It looks like you misunderstood my reply as a final solution, performance tickets require more time and debugging so I asked your feedback on the performance speed with the minimal install.

I agree WP requires more plugins to run sites and that's completely normal, I guess you also understand that with each plugin, the need for server resources will be increased.

Multilingual plugins work connecting all the plugins items and translating it, so it's normal that you find more need for resources when you add a new plugin because WPML (Multilingual Plugin) needs to check that plugin for translation, being so the resources needed will be double as:
- The new plugin own needs for resources
- WPML needs for resources to translate the new plugin.

The following can be the reason when the resources needs are high when adding a new plugin:
- Some queries inside either of the plugin, that's not optimized.
- Conflicts

Since we can see that WPML works perfectly on the normal installation and you confirm it, it looks like me compatibility issues with some plugins regarding performance. Being so, could you please disable all plugins first and enable the plugins one by one to see which plugin is creating the conflict?

Once we find the conflicting plugin, we can work with that plugin authors using our go global program to optimize that performance issue.

Look forward to your reply.

Thanks

June 12, 2019 at 2:29 pm #4005249

bentJ

Hello Shekhar,

Forgive me, you are right I misunderstood your reply. In my defence, it wouldn't have been the first time I got that as an actual final response from a developer, therefore, my reaction.

Yes, definitely I am expecting this to take a relatively long troubleshoot and debug process.

Our installation is not a real multilanguage site. We use WPML to change little things between Canadian and American English, and also for the multi-currency and with a more than usual amount of plugins it's only logical that it will require some optimization and debugging. Also, I'm sure I'm misusing or not utilizing some features correctly either.

The issue is page load times are getting more than comfortable and back-end is really a pain to work with atm.

We are not really using the translation abilities on many plugins and pages so maybe there are things we could get rid of?

In addition, I'm experiencing other problems now and then:

0- Initially the first challenge was the content. Since I couldn't start with a custom Canadian English language to set up with, I had to choose English + French, set up, delete french and place Canadian, build the website, switch to Canadian default. But now since all content is US English but default is Canadian, I had to translate everything even tho I don't need most of them and were fine with using the default one with both languages.
1- Store page: I had to switch to editing translations separately bc the design breaks in some elementor blocks if I use just the translator. (specifically blocks with handwritten inline CSS in them)
2- Business page has similar issues where again translating with the manager breaks some styling and also there are a couple of strings that string translator cannot capture even tho I scanned the plugins again.
3- Selecting multiple plugins or themes and scanning doesn't work. Have to do them one by one
4- Pages and translations seem to randomly break sometimes. Could not figure out why yet.

there are a few more that I cant place right now.

June 13, 2019 at 4:05 am #4009237

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I would request you to open a new ticket for the new issues as per our support policy we discuss only one issue per ticket, this will help both of us to debug a primary issue easily, I hope you understand.

We use WPML to change little things between Canadian and American English, and also for the multi-currency and with a more than usual amount of plugins it's only logical that it will require some optimization and debugging.

So this means you're not translating your pages to all languages? If you have similar content to show on both languages, you can use the display as a translated feature of WPML, this will display the same content without the need for duplication and translation.

More Details: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

Are you translating all of the strings available in the site? If you have just a few numbers of strings that need to be translated? Could you please go to WPML -> Themes & Plugin Localization -> Localization options -> How to translate strings in themes and plugins and choose " Don't use String Translation to translate themes and plugins" and see if it helps?

Look forward to your reply.

Thanks

June 13, 2019 at 5:42 pm #4016001

bentJ

Hello Shekhar,

I listed those issues as background information thinking those may help. No worries about them.

About translations, we use WPML to:
-Use the multi-currency
-Translate small bits and pieces (like saying Fleet tracking in US and Canadian Owned Fleet Tracking in CA, or Liters in Canadian or gallons in US)

I can't use appear as translated in most cases because:

WPML doesn't let us do the initial setup in a custom language (Canadian English) and:
-I had to create all initial pages in US English to not confuse Google and myself,
-then setup with US English and French
-After the wizard, remove french, add canadian as custom language and make it default.

As pages try to look for default page, I have to translate (mostly just duplicate) all content to Canadian.

After I feel comfortable I will rebuild this page from scratch. Do you think there is a better order to do this?

Lastly I tested with string translation option turned off but cant say I saw a bit difference.

The topic ‘[Closed] Slow action load times and slow queries’ is closed to new replies.