This thread is resolved. Here is a description of the problem and solution.

Problem: My site is running slow with WPML enabled.

Solution: The server was old and could not handle the site. Moving the site to a new server resolved the issue.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by Gianluca Destro 2 years ago.

Assigned support staff: Lauren.

Author Posts
March 28, 2018 at 10:33 am

Gianluca Destro

Website (front end and back end) are drastically slow using WPML plugin.
I often get a 504 Gateway Time-out. I have already disabled:
Auto ID adjust state (WPML > Languages)
- Track where strings appear (WPML > String translation)
- Auto register strings(WPML > String translation)

I have also asked to server admin to increase Php.ini values:
MAX_EXECUTION_TIME : 600
REQUEST_TERMINATE_TIMEOUT: 600
FASTCGI_READ_TIMEOUT: 300

March 29, 2018 at 3:10 pm #1560220

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I'm currently unable to reach your site, so I can't login to get more information. Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

Since performance issues can be difficult to pinpoint, let's check a few variables and settings to narrow the issue. Please answer as many of these questions as you can. Contact your hosting provider, if necessary.

Please keep WPML & all related plugins enabled while we do these steps:

1. The WP Memory Limit needs to be increased. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

2. Can you add debug information to the thread? Instructions: https://wpml.org/faq/provide-debug-information-faster-support/

3. If you haven't already, can you review the following article https://wpml.org/2012/01/can-your-site-run-faster/ to ensure all relevant steps are followed?

4. Can you tell me more information about the hardware including the CPU?

5. What type of hosting do you have? Shared, VPS, Dedicated, etc?

6. Do you know if object caching is part of your PHP setup? PHP < 5.5 should be APC. Newer versions should use the zend op cache, uAPC will also work though but is slower.

7. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen) ?

8. Are you using a cache plugin such as W3 total cache?

9. Make sure Disk caching is disabled.

10. Try disabling the W3 total cache plugin.

Thank you for helping us pinpoint the issue. Feel free to add any other information you may have.

March 29, 2018 at 3:31 pm #1560245

Gianluca Destro

Hi Lauren, after many tests, I realize that the server machine was too old to support even a quit lite wordpress multilingual website, so I'm moving it to a better machine. Thank you for your advice, I will check it once I Have moved the hosting. You can close the ticket, for now, I will be back if I need some help to improve performance related to WPML plugin.