This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

This topic contains 12 replies, has 2 voices.

Last updated by thierryO 5 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 27, 2019 at 5:39 pm #3696015

thierryO

Whenever I activate WPML Translation Management, my pages take about 1 min to save and 5-10 seconds without it. All WPML plugins are up to date.

April 29, 2019 at 11:42 am #3702817

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

We recently released new versions of WooCommerce Multilingual plugin version 4.6.2.1 which fixes some performance issues. Being so, may I kindly ask you to update the plugin to the latest version, it would also be nice if you can check the problem with the latest version and share with us the results.

BACKUP NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Look forward to your reply.

Thanks

April 29, 2019 at 4:09 pm #3705279

thierryO

Hi,

I just upgraded but it's not faster. It takes a good 30 seconds - 1 minute to save my home page.

April 30, 2019 at 1:56 pm #3711945

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

I understand you are having site performance issues. Since performance issues depend upon the site, the server, plugins used and furthermore. I would need your help to narrow down the issue. Could you please provide feedback on the following questions as much as possible?

#1
Can you please review the following articles and see if all the relevant steps are covered?
https://wpml.org/faq/prevent-performance-issues-with-wpml/
https://wpml.org/2012/01/can-your-site-run-faster/

#2
Try disabling and re-enabling all WPML plugins and then going to WPML > Support > Troubleshooting and press the "Recreate ST cache tables" button.

The first visit after the re-activation of the plugins is kinda slow, but after the regeneration of the tables - it will be better.

#3
What type of hosting do you have? Shared, VPS, Dedicated, etc?

#4
Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

Thank you for helping us pinpoint the issue. Feel free to add any further information you may have.

Look forward to your reply.

Thanks

May 3, 2019 at 4:16 pm #3736691

thierryO

Hi,

I just tried all of the recommended steps and nothing improved the performance, except by deactivating either WPML String Translation or WPML Translation Management. It's when they run both at the same time that I have MAJOR performance issue. I go from about 5 seconds to save a page to a good 20-30 seconds.

May 6, 2019 at 9:33 am #3746527

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Would you please provide feedback on the #3 & #4 point too, it will help me to pinpoint the issue further.

Look forward to your reply.

Thanks

May 6, 2019 at 11:48 am #3748011

thierryO

Hi,

#3 the site is hosted on a dedicated server so there are plenty of ressources available.

#4 yes I can disable all plugins and use any wordpress default themes and it's still slow if I have both translation management and string translation enabled

May 7, 2019 at 11:58 pm #3762617

thierryO

Hi,

The migration process is on it's way! It should take a few more minutes to complete.

I will report back if I face any issue.

Thanks.

May 8, 2019 at 12:27 am #3762807

thierryO

Do you need WordPress access? How may I send you this privately?

May 8, 2019 at 11:03 am #3765783

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

No need for the login details, I will create login details same as the provided sftp details so you can also login afterward to check the issue.

I can see that you have still enabled "auto-register strings" option which should be disabled, you can go to WPML->String Translation ->Auto register string from translation and disable it. https://wpml.org/faq/why-string-translation-appears-to-slow-down-sites/

Then I went to WPML > Support > Troubleshooting and pressed the "Recreate ST cache tables" button.

After this, I tried to update the homepage and I can see the homepage is updated in 10~15 seconds, so could you please try to see if the performance in the newly migrated site and share us your feedbacks?

Look forward to your reply.

Thanks

May 8, 2019 at 6:41 pm #3770051

thierryO

Hi,

There is no way to disable it, all I can do is uncheck all the boxes from the Auto-register strings from these text domains popup. Is that what you mean? I just tried to uncheck all the boxes and it indeed takes about 15 seconds to save the home page which is an acceptable delay. But now I am wondering, what impact will it have on my site to have theses boxes unchecked?

Because on your FAQ that you sent me, it says the following :

However, recent changes in the way we handle strings have shown a performance improvement when you auto register strings for translation. Because of this, we recommend to make use of it.

So I am not sure to understand how disabling it should improve the performance when it says otherwise.

Thanks.

May 9, 2019 at 3:22 am #3772615

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can do is uncheck all the boxes from the Auto-register strings from these text domains popup. Is that what you mean?

Yes, that's what I mean.

But now I am wondering, what impact will it have on my site to have these boxes unchecked?

These options auto-registers the strings for themes/plugins, disabling this will disable this feature, but you can register the strings using the below steps:

1) Go to WPML->Themes & Plugin localization and check the "Translate the theme and plugins using WPML's String Translation" checkbox
2) Once saved go below the page under "Strings in the theme/plugins"
3) Choose the theme that you are using and select the "Scan the themes/plugins for strings" Button
4) Once the scanning process is finished, go to WPML->Strings translation - Search for the strings and translate them to the secondary languages.

https://wpml.org/documentation/getting-started-guide/string-translation/

So I am not sure to understand how disabling it should improve the performance when it says otherwise.

It's currently showing that disabling this feature on your site is showing an increase in performance so keep that checkbox unchecked, In some of the versions enabling this has helped so they have kept that in the documentation.

Let me know if this helps.

Thanks

May 10, 2019 at 3:22 pm #3786137

thierryO

My issue is resolved now. Thank you!