This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Delay during change from main language to secondary language Solution: See this for an explanation and solution: https://wpml.org/forums/topic/delay-when-switching-between-languages/#post-893228

This topic contains 2 replies, has 2 voices.

Last updated by martinS-75 5 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
May 3, 2019 at 4:44 am #3730827

martinS-75

I've added a language switcher in the main meny of my site.

The problem is that there is a delay of 1-2 seconds before the actual language switch takes place. Then there is also the normal page load after that.

Why does it take 1-2 seconds before anything happens?

See my site at hidden link and try to change to english language, and you will see what I mean.

This is happening on a desktop computer with google chrome.

May 3, 2019 at 9:17 am #3732531

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

I can see the issue and I think that this might be the cause (and hopefully the solution, as there are no really other options to try at this point):
https://wpml.org/forums/topic/delay-when-switching-between-languages/#post-893228

Can you have a look? On a side note, when I analyze the network on your site, there is 1.5 sec delay coming from fbevents.js as it seems.

Regards,
Bruno Kos

May 3, 2019 at 2:24 pm #3735247

martinS-75

My issue is resolved now. I used the link you provided.