This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Bruno Kos 4 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
May 12, 2019 at 4:42 pm #3793453

Matthew Edwards

I am trying to: Navigate around WordPress, between pages on my site and switch to the 2nd language (Spanish).

When I deactivate the WPML plugins, particularly WPML Multilingual CMS. The page speed resumes to normal.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: slow loading pages

May 13, 2019 at 10:42 am #3797123

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Could you grant the access to the site so that I could see the issue? I am getting a Wordfence notice - see the image.

Regards,
Bruno Kos

May 14, 2019 at 7:26 am #3804275

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I've run a test with WPML and without WPML:
- no WPML:
hidden link

- WPML active
hidden link

However, can you tell me if the speed issue is in the backend of the site and is that where I should focus my testing?

Regards,
Bruno Kos

May 14, 2019 at 10:16 pm #3810967

Matthew Edwards

Hi!

I would say the backend? With the plugins activate it can take 30 seconds+ to navigate around to different pages. Switching from English to Spanish seems to take much longer (89 seconds), or even to the point where the site will go down and I get a 503 error.

With the plugins deactivated, about 5.3 seconds to load each page.

May 15, 2019 at 6:52 am #3812673

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It definitely seems like the backend of the site and the results seem to be like:
- browsing through various non-WPML setting works fine
- browsing through some WPML options is very slow, like opening Language or String Translation

Therefore, can I ask you the following then? In order to debug this issue, can you install Duplicator plugin and create package so that I can try this on my localhost and possibly escalate further to 2nd tier?

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

Regards,
Bruno Kos

May 20, 2019 at 8:48 am #3845039

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you also provide installer.php? It is also available there (with Duplicator) and a rather small file, but contains proper archive URL and some other info related to particular installation.

Regards,
Bruno Kos

May 21, 2019 at 8:56 am #3853355

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I've done some testing on my localhost and generally it was very fast (WPML + ST + all other plugins active). Loading times in the frontend and the backend of the site were usually somewhere between 1.5 and 3 seconds. You do have several heavy plugins, such as Accelerated Mobile Pages, WPBakery Page Builder and few other that may affect loading times in the backend of the site (due to various scripts being loaded).

On your live site, you can try activating this setting:
WPML -> Theme and plugins localization -> Don't use String Translation to translate themes and plugins, as this will mean that strings for all plugins and themes will not load from ST tables, hence reducing load significantly. Apart from what, not sure what else to suggest.

Regards,
Bruno Kos