Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 -
- 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 2 replies, has 2 voices.

Last updated by Long Nguyen 3 months ago.

Assisted by: Long Nguyen.

Author Posts
November 21, 2023 at 5:10 am

frankR-32

my website insektenliebe.com was not redirecting to insektenliebe.com/de. I used this guide to make changes https://wpml.org/errata/wpml-default-language-in-directory-does-not-redirect-properly/

it worked , but then website load time has increase. I change that plugin file back like it was , redirect works at /de but you can see load times.

i disabled all plguins , and enabled only wpml plugin , issue remains.

November 21, 2023 at 6:30 am
November 22, 2023 at 1:49 pm #14898605

frankR-32

no response yet ???

November 24, 2023 at 7:14 am #14913423

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi Frank,

Thank you for contacting WPML support, I'd be happy to help you with this issue.

Sorry for the delayed response - it has been a full queue for the past few days and it can take a bit longer to respond.

You can try to revert the workaround from the documentation https://wpml.org/errata/wpml-default-language-in-directory-does-not-redirect-properly/
and go to admin area > Settings > General > Set WordPress and Site Address (URL) to "hidden link", notice the slash (/) at the end > Save changes and save permalink settings to see if it helps.

Also, you are using the option "Use directory for default language", you need to have a root page. Please follow the documentation below to redirect the root page to the default language directory.
https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/#redirect-the-root-domain-to-the-default-language-directory

Look forward to your reply.
Thanks

The topic ‘[Closed] Slow Loading when "Use directory for default language" option is enabled.’ is closed to new replies.