This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by Bruno Kos 6 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
March 26, 2019 at 5:06 pm #3464925

davidK-20

WooCommerce and WPML perform rather slow. If WPML is enabled the site load times are doubled for all the pages that are not cached. In this particular instance I tried to open the cart page. Load times are around 4s vs. 2s.

Web server is running on a Quad Xeon CPU with 16GB of RAM and the database is on an Quad Xeon CPU with 32 GB of RAM and an SSD. Memory Limit is 256MB for PHP which should be more than enough.

Below is the output of Debug Objects first with WPML turned on and then with WPML turned off

https://pastebin.com/3Vb8t7W8 <-- WPML Enabled

https://pastebin.com/LhFdEptw <-- WPML Disabled

I also attached images of the Xdebug output you can see that the number of PHP calls that are made when WPML is enabled and when it is disabled.

I did everything that your tutorials recommended for speeding up WPML and I am still facing with his problem.

March 27, 2019 at 9:42 am #3469163

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you give me some idea on the number of products you have on the site, orders, pages, strings and other types of the content?

Regards,
Bruno Kos

March 27, 2019 at 10:34 pm #3476003

davidK-20

Well in the shopping cart I had two items for testing. So the number of orders, pages, items, ... in the shop shouldn't matter that much. The database access is quite fast and shouldn't pose a problem, it's the sheer number of queries that bogs everything down.

There are a few thousand orders in the database and there are around 1500 different items in the WooCommerce database.

About the strings I'm not sure, WP Bakery did quite a mess with the strings, but they aren't being translated.

March 28, 2019 at 9:02 am #3478517

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you tell me the if the following settings are OFF or disabled:
- Adjust IDs for multilingual functionality (WPML > Languages)
- Track where strings appear (WPML > String translation)
- Auto register strings(WPML > String translation)

I've asked our 2nd tier support for an opinion (based on Debug Objects results) and will reach out once they get back to me.

In the meanwhile, would you be willing to provide me with temporary WordPress admin username so we could investigate the issue directly and check how the site is set? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

Regards,
Bruno Kos

March 28, 2019 at 10:26 am #3479415

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Another thing - can you provide information related to "Page generated in" times with WPML active and not active for the Cart page e.g.?

Also, can you provide full data information related not only to query numbers but also to how long each query takes? You can try using plugin like this one to generate a screenshot if that's convenient for you:
hidden link

Or trying with:

 define( 'SAVEQUERIES', TRUE );

https://wpml.org/faq/how-to-debug-performance-problems/

Regards,
Bruno Kos

The topic ‘[Closed] Slow performance and excessive DB queries’ is closed to new replies.