This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by danielm-115 2 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
June 5, 2019 at 10:17 am #3959409

emyM

Hello guys!
I'm experiencing some problems related to the dashboard speed of my website.

First of all, the Time to First Byte increases several times when WPML + WPML plugins are installed :
TTFB without WPML plugins: 0.743s -> hidden link
TTFB with WPML plugins: 2.75s -> hidden link
As far as I can tell. "WPML String Translation" is the one increasing the most the TTFB value:
TTFB with WPML plugins except "WPML String Translation" plugin: 1.12s -> hidden link

Secondly, after installing "Query Monitor" plugin, all the slow queries seems to come from WPML: hidden link .

Thirdly, I also tried to debug the queries with "Debug Objects" plugin. When inspecting the "DB Cache" section, there are several orange highlighted boxes coming from WPML plugins: hidden link

Are these some known issues? Do you have any suggestions for what I can do to speed up my website?

Please know that I have the memory_limit set to 1024M and I have already tried the following:
1. WPML -> String Translations -> Auto register strings for translation -> Edit -> unchecked everything hidden link
2. WPML -> Languages -> Make themes work multilingual -> unselected: hidden link
3. Cleanup the wp_icl_strings table with this query -> DELETE FROM `wp_icl_strings` WHERE status = 0;

I'm looking forward to your reply, thank you

June 5, 2019 at 11:12 pm #3964453

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support forum.

Could you please apply the suggested settings from our guide of preventing performance issues with WPML?

You can find the guide here:
https://wpml.org/faq/prevent-performance-issues-with-wpml/

In case those settings will not solve the issue we can offer to migrate zour website to our test server for further debugging and escalate to our developers if necessarz.

Let me know if this might beconvenient for you.

Kind regards
Andreas

June 6, 2019 at 9:16 am #3967491

emyM

Hello Andreas!

I have followed all steps from the article you sent me. The TTFB indeed is a little lower now, but unfortunatelly the queries are still slow.

"In case those settings will not solve the issue we can offer to migrate zour website to our test server for further debugging and escalate to our developers if necessarz."

- Yes this would be convenient. Please just let me know what you need from me here.

June 6, 2019 at 5:27 pm #3971197

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have sent you a private message with instructions in regards to migrating your website towards our test server.

Please leave me a short notification once the migration is completed.

Kind regards
Andreas

June 7, 2019 at 9:50 am #3975435

emyM

Hello again Andreas!

Thank you for your help with this issue related to the dashboard speed. The migration is completed.
I'm looking forward to hear from you, thanks again!

June 7, 2019 at 6:29 pm #3978439

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing you to let you know that I am investigating about the performance issues on your site.

Anyhow, when setting up a minimal setup with WPML plus add-ons and WooCommerce only the performance is normal.

Can you confirm similar page generation times when running your site with the same plugin setup? (see screenshot) Otherwise, the issue might be server related.

I will need some more time to figure out which plugins are causing the issues, as when all plguins are active there is a significant page generation time and slow querries. I will investigate in how far this is linked to WPML and contact you soon.

If necessary I will escalate the ticket afterwards to our developers for further investigation.

Kind regards
Andreas

June 10, 2019 at 9:54 pm #3990541

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your patience.

I have been debugging your site and I realized a PHP error related to the Plugin WooCommerce Multi Currency Premium. Deactivating the plugin enhances the performance of the website.

I am not sure if the issue might be connected to WPML as WooCommerce Multilingual also offers a multilingual currency feature. Let me know if you got any questions or need assistance in regards to the feature.

On our testserver your migrated site runs with a page generation time between 2-3 second. Deactivating the WooCommerce Multi Currency Premium lowered the delay for around one second. The screenshot called "debug" shows the result after deactivating the plugin.

I would like to invite you to install the plugin WooCommerce Multi Currency Premium on the following test site in order for to test it with a new installation of WordPress including WPML.

One Click Login: hidden link

Leave me a short notification once the plugin is installed.

I also attached a screenshot with 2 slow querries that are related to scripts for loading fonts and CSS, but they are not related to WPML.

Another screenshot show 3 duplicated querries which are related to WPML. As I did not have the chance to see your live site yet I would like to ask for credentials in order to verify the queries on your live site. What is the page generation time currently on your live site?

You might further consider to update PHP on your server. We recomend at least version 7.1 and a higher version will always lead to a better performance. You are currently still running version 7.0.33.

Further, please try using a Cache Plugin in order to enhance the site performance. We can recommend W3 Cache for this task:
https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/

Please let me know about the results after deactivating the above mentioned plugin. Also make sure to deactivate plugins that are currently unnecessary.

As you are using a huge amount of plugins consider to keep plugins deactivated in case they are not really necessary. Further, consider changing the PHP Memory Limit (php.ini) to 1024M and raise the WP Memory Limit (wp-cofig.php) to 512M.

Kind regards
Andreas

June 11, 2019 at 7:11 am #3992361

emyM

Hello Andreas! Thank you for your feedback. Below are some updates:

1. First of all this is the time response from my environment with a minimal setup only Woocommerce and WPML related plugins active: 0.53s (screenshot: 1.png)

2. After activating WooCommerce Multi Currency Premium, the page generation time did not increased (screenshot: 2.png)

3. Seems like I can't find the PHP error you were talking about generated from the "WooCommerce Multi Currency Premium" plugin (screenshot: 3.png).

4. The Page generation on the live site after installing all the plugins is around 1.88s (screenshot 4.png)

5. "WooCommerce Multi Currency Premium" plugin is installed on the WordPress location provided by you

6. I'm going to have a look on the w3total cache setup for wpml and let you know if I see any improvement.

7. In terms of memory_limit from php.ini this was already set to 1024M , but I just set the wp memory limit to 512M and didn't see any improvement.

Please let me know if you still want to have a look on our live server and if you do, advise me on how I should send you the credentials.

Thank you

June 11, 2019 at 4:08 pm #3997135

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please provide us a download link for a Duplicator Package of your site or provide access in order for us to obtain a copy.
hidden link

I have enabled the private fields for submitting the information.

Once we obtained ca copy of the site I will be able to escalate it to our developers who will have a further look at the issue.

In the meantime please try using a Cache Plugin in order to optimize the site performance.

Kind regards
Andreas

June 13, 2019 at 12:47 am #4008169

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you very much for the provided information.

The your site has been escalated to our developers for further testing. We are working on solving current performance issues with the upcoming update for WPML Multilingual CMS.

In case I will receive additional feedback in reagrds to your site's issue I will be on contact with you.

Kind regards
Andreas

August 6, 2019 at 12:30 pm #4347327

emyM

Any update on this?

September 5, 2019 at 3:14 pm #4520399

danielm-115

I'm having the same problem with TTFB, and I tracked the problem down to the WPML plugins. Its a heavy site with woocommerce, subscriptions, memberships and so on but the queries and TTFB hits +3sec when activating WPML the backend is so slow that it sometimes takes 20sec to load a page.

I'm caching pages so that the end use doesnt notice it to much but some pages like event pages are not cached and are having insane loading times.