Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 4 voices.

Last updated by Alejandro 2 years, 6 months ago.

Assigned support staff: Alejandro.

Author Posts
October 31, 2018 at 1:22 pm #2865921

martinH-16

My site is very slow using WPML.

I already deleted non translated strings from DB but it didnt helped. I looked to the slow queryies and it si definitely a wpml. Check the screenshot.

Can you help?

_PHPsetup.png
_slow.png
October 31, 2018 at 3:32 pm #2866507

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello!
You might want to try to re-create the String Translation DB cache tables.
That option is located in WPML > Support > Troubleshooting - Recreate ST DB Cache tables

It is not enough to just remove the non-translated strings - you have to run that as well - and as you can see the affected tables by that query are: icl_string_pages and icl_string_urls

November 6, 2018 at 5:01 pm #2882026

martinH-16

I did recreate the cache, but Query is now even slower than before. Any advice?

2018-11-06_18-00-02.png
November 6, 2018 at 5:03 pm #2882040

martinH-16

Query monitor also shows lot of duplicate queries which looks like from WPML.

November 7, 2018 at 2:36 am #2883359

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please review the following documentation and follow the steps within it, once done let me know your results

https://wpml.org/faq/prevent-performance-issues-with-wpml/

November 12, 2018 at 2:20 pm #2898841

martinH-16

Ok I followed:

1. Adjust IDs for multilingual functionality - https://wpml.org/faq/prevent-performance-issues-with-wpml/#1-automatic-adjustment-of-ids-for-multilingual-functionality

2. Using WPML String Translation - https://wpml.org/faq/prevent-performance-issues-with-wpml/#2-using-wpml-string-translation

3. Deactivate tracking of strings - https://wpml.org/faq/prevent-performance-issues-with-wpml/#3-deactivate-tracking-of-strings

4. Auto-registering strings for translation - https://wpml.org/faq/prevent-performance-issues-with-wpml/#4-auto-registering-strings-for-translation

5. PHP and MySQL versions - 7.1, MySQL 5.6
6. Memory Limit - 256MB
7. Cache - I am trying to use the W3 total cache ( I can not use minify - it crash the site)
8. I contacted Toolset support - They told the problem is not with their queries, but with WPML queries. I am sending the queries in screenshots

9. Version of WordPress and WPML - latest

Page is still slow. I will try another caching plugins. But it seems like it does not help.

wpml.png
wpml caller.png
slowest queries page 1.png
slowest queries page 2.png
November 14, 2018 at 2:20 am #2904837

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

What is your site's speed with WPML deactivated and then with WPML activated ?

Also what are your settings set to within WPML->Theme and Plugin localization

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

November 21, 2018 at 12:36 pm #2926551

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello Martin,

Hello, my name is Alejandro.

Since Bobby currently has a few days off, I will replace him here in the forum.
I hope this is OK with you.

let's start with access to your site (WordPress credentials), because i would like to check a few things and can only do that from your server.

Plus, try wp-fastest cache instead of W3. In the meantime, i'll run a few tests of your site to see what's going on (from the outside, of course).

I will not touch anything on your installation i will just check your entire installation.

The topic ‘[Closed] Slow query’ is closed to new replies.