This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Slow saving on frontpage which ends in a 500 error.

Solution:
By enabling WP Debug mode we found the readable PHP error:

[02-May-2019 07:52:40 UTC] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/vhosts/restaurantkrydderiet.dk/httpdocs/wp-includes/class-wp-hook.php on line 115

So Increasing max execution time fixed this.

Tagged: 

This topic contains 18 replies, has 2 voices.

Last updated by thomasR-59 4 months, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
April 28, 2019 at 11:12 am

thomasR-59

I am trying to: Make changes to the english/danish frontpages

Link to a page where the issue can be seen: hidden link

I expected to see: An site which i can edit the english/danish version of the page.

Instead, I got: an 500 Error.

If i run the page without any plugins and only elementor the page editor works, but with wpml it wont let me save the changes done to the frontpage.

It's an direct clone of the page hidden link just with small content changes, and we are not having any issues with that page.

We got daily backups of the sites, and you are welcome to make a clone for local usage.

April 28, 2019 at 11:31 am #3697829

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

May 2, 2019 at 8:40 am #3722751

thomasR-59

Sorry for the late answer, we are very busy atm. 🙂

Sure thing.

Log file:
[02-May-2019 07:52:40 UTC] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/vhosts/restaurantkrydderiet.dk/httpdocs/wp-includes/class-wp-hook.php on line 115

That part controls the callback priorties of hooks.

i tried adding more execution time though the wp-config file, which didn't help.

I just tried to add more execution time though the htacces.
Which killed the site 100%, even when i removed the code line it keept throwing a permanent 500 error.

i had to do a full restore of the site.

(So i would not recommend doing it that way).

May 5, 2019 at 4:31 pm #3743545

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ok, so I assume that your hosting doe not allow you to do this your self.
Please contact your hosting support and ask them to
1. increase you package Maximum execution time
2. increase it in wp-config.php as well.

Let me know how it goes.

Regards,

May 6, 2019 at 9:20 am #3746281

thomasR-59

It's now set to 120sec though server level. And its still failing execution after 120 sec...

[06-May-2019 05:25:44 UTC] PHP Notice: Undefined index: hook_suffix in /var/www/vhosts/restaurantkrydderiet.dk/httpdocs/wp-admin/includes/class-wp-screen.php on line 212
[06-May-2019 09:16:16 UTC] PHP Fatal error: Maximum execution time of 120 seconds exceeded in /var/www/vhosts/restaurantkrydderiet.dk/httpdocs/wp-includes/wp-db.php on line 2007

May 6, 2019 at 1:11 pm #3748787

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

[06-May-2019 05:25:44 UTC] PHP Notice: Undefined index: hook_suffix in /var/www/vhosts/restaurantkrydderiet.dk/httpdocs/wp-admin/includes/class-wp-screen.php on line 212
- this issue does not come from WPML
- disable all the plugins and check this.

[06-May-2019 09:16:16 UTC] PHP Fatal error: Maximum execution time of 120 seconds exceeded in
- please increase it even more and check.
- if you see still it does not take effect ask this with your hosting provider.

Temporarily disable the WPML and check all these issues.

Let me know how it goes.

Regards,

May 6, 2019 at 1:28 pm #3748953

thomasR-59

Just disablede wpml, now its saves in less than 2 sec.

No errors in the log, i even tried by disabling all plugins and only running elementor and wpml. Still saving issues and errors in the log.

May 6, 2019 at 2:08 pm
May 7, 2019 at 9:15 am #3755777

thomasR-59

Hi Riffaz

The website is now migrated

May 7, 2019 at 11:24 am #3757025

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You are facing this issue in homepage and you are using Elementor editor, right?

When I check this in the migrated site I do not see 500 error but it keeps loading when I try to save the changes on the homepage.
Did you check this on the migrated site?

Regards,

May 13, 2019 at 7:03 am #3795545

thomasR-59

Hi Riffaz,
Yes the issue is the frontpage, it's only sometimes it will state that it was an error. Otherwise it will be perma stuck loading when saving.

Also i checked it out on the migrated site, and it seems like the styling is broken for the website (unless it's for testing purposes).

May 13, 2019 at 4:31 pm #3800545

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am able to save your homepage in your live site now and I translated hundred percentage : hidden link

Could you please try and confirm ?
I tried three times and all was success without any error.

Regards,

May 15, 2019 at 11:25 am #3815589

thomasR-59

I can't save the homepage, if you go and make changes to the frontpage though elementor it will stall forever.. and suddenly it just gives up, and give you the option to press the save button again.

May 15, 2019 at 11:56 am #3815953

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Thomas,

Thank you for the details.

This was reported by another user as well.
After a lot of checking ended that the method his theme is using to handling the plugins caused this.

Could you please switch the theme to a a default theme like twenty seventeen and check the issue?
If that does not cause the issue we need to check this in a fresh installation.

Let me know.

Regards,

May 15, 2019 at 12:17 pm #3816301

thomasR-59

Hi Riffaz.

I just tried running on the twnety-twelve theme, it's the same issue.
Gonna try and deconstruct the entire page, block by block, and give an update-