Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by annekeL 1 month ago.

Assigned support staff: Andreas W..

Author Posts
April 19, 2021 at 12:03 pm #8572025

annekeL

Tell us what you are trying to do?
I've tried all kind of things, like
- updated plugins and theme (jupiter)
- set memory_limit to 256m
- emptied cache
- search the forum for solutions and tried them all (see below)

Is there any documentation that you are following?
https://wpml.org/forums/topic/slow-site-with-wpml-and-jupiter-theme-cant-use-the-customizer/

Is there a similar example that we can see?

What is the link to your site?
hidden link

April 21, 2021 at 4:01 am #8586395

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I see that the page load time expands to more than 30 seconds when trying to change the language.

Please enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

Then go to the homepage and switch the language. WordPress will gather errors in real time.

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the results. In case the debug-log is very long please add it to a web tool like pastebin.com and send me the link.

Kind regards,
Andreas

April 21, 2021 at 9:58 am #8589195

annekeL

Hi Andreas,

Thanks for your reply.
The page load time is indeed more than 30 seconds 🙁

Our server doesn't create a debug.log file, but instead writes all errors and warnings created by WordPress into a separate log file. I tried to copy the lines in the logfiles from 3 am untill 4.30 am this morning (April 21), so hopefully you can find something that causes the long loading time:

https://pastebin.com/iqP1J6AV

If you need anything else, please contact me.

Kind regards,
Remco

April 22, 2021 at 12:08 am #8595209

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Remco,

Does the issue get solved if you disable:

"Magic 360 for WooCommerce"

It seems there might be an issue between the plugin and our WooCommerce add-on.

If you could confirm this please, otherwise I can offer to take a copy of the site for debugging.

The private reply form is enabled. Please provide me access as admin.

Best regards
Andreas

April 30, 2021 at 2:43 am #8658547

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have taken a complete copy of your website and tested it on a virtual server without issues. The page load time is always about a little less or more than 3 seconds. See screenshots.

The only plugin that I am not able to test on this virtual server is "Really Simple SSL".

If the issue still persists on your site, does it get solved once you disable "Really Simple SSL"?

Further, the migrated site is by default using a default wp-config.php and .htaccess-file and I am running PHP 7.3.21 on mySQL 5.7.31.

I would further suggest you check for errors inside the wp-config.php file and also test with a default .htaccess-file which you can find here:

https://wordpress.org/support/article/htaccess/

Best regards
Andreas

German 366 seconds.jpg
English 324 seconds.jpg
Dutch 299 seconds.jpg
April 30, 2021 at 1:38 pm #8663107

annekeL

Hi Andreas,

Thank you for testing en analyzing.
Unfortunately disabling the plugin 'Realy Simple SSL' doesn't fix the problem.
Php version is 7.4.15 and MySQL version is 10.3.28... good enough.

Could it possibly be an server problem? Because on your server the problem doens't exist.

Kind regards,
Remco

April 30, 2021 at 8:52 pm #8665277

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Yes, according to my test the issue seems server related.

I would suggets checking with the hosting support for the erver error.logs.

Mavbe you could try a PHP downgrade to 7.3. Further, it seems the server is using MariaDB instead of MySQL. Maybe an update to the latest stable version 10.5.9 could also solve the issue.

Further, I did take a look at the site and it seems the loading time got better and is now about less than 8 seconds. There are varios 301 redirects indside the .htaccess - I would suggest i replacing the file with a default version, as mentioned earlier, solves the issue.

Best regards
Andreas

May 11, 2021 at 2:01 pm #8740991

annekeL

Hi,

My issue is resolved now, however I don't know how...
Suddenly the website is loading very fast. I contacted the hosting support, but they told me the website was the problem, not their server. Last week I checked the website and everything was fine, without any adjustments on my side.

Anyway, thanks for your support and testing.

Kind regards,
Remco