This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 17 replies, has 3 voices.

Last updated by Andrés 3 months ago.

Assigned support staff: Andrés.

Author Posts
July 8, 2019 at 7:01 pm #4165207

nikolaosP-5

WPML is very slow. Please help me.
hidden link

July 9, 2019 at 7:29 am #4168097

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

we have put together a documentation on how to prevent performance issues when using WPML if possible please review it and try the steps listed

-> https://wpml.org/faq/prevent-performance-issues-with-wpml/

let me know your results please

July 9, 2019 at 8:52 am #4168813

nikolaosP-5

Hi,
I did already all steps from performance guide.
I have sent also a debug information.

July 9, 2019 at 5:53 pm #4173597

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for updating me

sometimes increasing the memory of PHP memory limit also has a positive effect on the performance of the site.
https://docs.woocommerce.com/document/increasing-the-wordpress-memory-limit/

if even after increase your WP MEMORY LIMIT you are still experiencing performance issues if possible please let me know how you are currently measuring your site's performance (are you using a query monitor ? if yes please share the queries with me so i can have a better idea when testing as well)

also please provide me with a duplicator package so we can further test this locally and run some performance tests on our servers

to get the duplicator package you can use the duplicator plugin
=> https://wordpress.org/plugins/duplicator/

July 9, 2019 at 7:35 pm #4174085

nikolaosP-5

Hi,
I am using "Query monitor" to watch queries. Also I used mysqltuner.pl to optimize Mysql .
Right now I increased PHP memory to 384M. But it seems no difference.

I noticed, that slowdown happens, when WPML plugins are enabled ( Media , Strings etc.)

I would like to check on your servers, so I can see better where is a problem.

How do I send to you the Duplicator archive ?

July 9, 2019 at 8:28 pm #4174257

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

you can share the duplicator in the following reply i have enabled it as private

additionally if you wish i can migrate the site to our cloudways staging servers where you will have access to it to test as well

to do this i can either do it for you by accesing the backend or provide you with the information needed from your side to do it

please let me know how you would like to proceed

July 10, 2019 at 9:49 am #4177879

nikolaosP-5

Hi,
I send you a PM with SFTP access

July 11, 2019 at 2:22 pm #4190803

nikolaosP-5

Hi Bobby ,
I see that difference indeed is not so big.
Would you tell me please the specs of your server ?
CPU, RAM , PHP memory, MySQL config ?
Perhaps my server is not configured very good.

July 11, 2019 at 2:53 pm #4191173

nikolaosP-5

To compare:
Your server
hidden link load time 1.35 sec
My server hidden link 5.25 sec

This is 5 times more longer wait time.
I have a VPS server with 4Gb RAM

July 15, 2019 at 7:20 am #4207639

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

My name is Andrés and I'll take care of your ticket from now if you agree. 🙂

For answering your question, our Cloudways server has:
- PHP 7.0
- MySQL 5.5
- Memory Limit 512M
- RAM 1G

I would recommend you to modify and increase your Memory Limit and WP Memory limit to higher values than 384M if it is possible. Also, contact your hosting provider and to validate and improve your server configuration.

Regards

July 15, 2019 at 8:22 am #4208193

nikolaosP-5

Hi Andres!

My hosting company would not do much about this , I rent an empty VPS , and installed Centos on my own.

Now I raised PHP limit to 512M
and in wp-config.php
define('WP_MEMORY_LIMIT', '512M');
define('WP_MAX_MEMORY_LIMIT', '512M' );
But no diference at all.

Can I send you a private PM ?

July 15, 2019 at 1:05 pm #4211315

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Sure, next message will be private.

July 16, 2019 at 9:44 am #4218269

nikolaosP-5

Hi Andres,
I am sending to you environment configuration from Query Monitor.
I tried to set settings same for MySQL, and I set a PHP memory up to 512 M

Also , I changed Apache to cgi-fcgi .
Page load improved almost 5 times.

Do you have some suggestions what can I do next to improve it ?
Does your hosting on Phpstack using external MySQL server ?
I believe problem is MySql performance bottleneck .

July 16, 2019 at 11:57 am #4219941

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hey there

I'm glad to know that your site is 5 times faster than before! 🙂

For answering your question, our MySQL is installed in the same server. Maybe you can find the following tutorial helpful:
hidden link

Regards

July 17, 2019 at 7:37 pm #4233175

nikolaosP-5

Hello Andres, I will take article in consideration.
Please remove immediately from my reply 3 screenshots from my browser.
I asked you before for private reply . Why did it become public now ?