This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by Dennis 7 months, 4 weeks ago.

Assigned support staff: Dennis.

Author Posts
January 23, 2019 at 4:02 pm #3121466

talC-2

Hi

I am trying to sort out the custom slag property from english the spanish

Although Translate custom post and taxonomy base slugs (via WPML String Translation). is ticked

Properties (estate_property) is translated -the slag in not

For example:

hidden link

hidden link

Same her:

hidden link

hidden link

The word property in the first example and the slag property/sale are not translated in the urls

Also, can I get rid of the -es in all translations of taxonomies?

January 24, 2019 at 6:51 am #3123574

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please confirm that you have translated the post type Properties (estate_property) at WPML > Settings > Post Types Translation section. Under your post type (should be set to translatable), click 'Set different slugs in different languages for [your-post-type]'. Enter your slug translation for your secondary language. Click 'Save'.

Then re-save your permalinks at Settings > Permalinks. Just click 'Save Changes'

To get rid of the '-es' from you taxonomy slugs, you can try to set your taxonomy (esporles) to 'Translatable - use translation if available or fallback to default language' in WP > Settings > Taxonomies Translation and remove the slug translation of that taxonomy. Then re-save you permalinks.

Does it help? Please let me know.

Kind regards,
Dennis

January 24, 2019 at 7:27 am #3123736

talC-2

Both are done but still it doesnt work

All steps are set correct and still I get property not Propiedad in slag

When I remove i Spanish taxonomy the -es I get:

The slug “ibiza” is already in use by another term.

January 24, 2019 at 7:48 am #3123792

talC-2

2nd problem is resolved more or less but the first one I need to solve

January 24, 2019 at 8:21 am #3123897

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your replies.

Could you please share your Debug information with me?

You can read the detailed explanation about it here.

http://wpml.org/faq/provide-debug-information-faster-support

The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Meanwhile, please try the following steps and check if the issue still exists. Please make sure to make a complete backup of your site before proceeding.

-Go to WPML>>Support page
-Click on Troubleshooting link (link in the middle of the page)
-In Troubleshooting page, please click on the following options of 'Clean up' section. Wait for confirmation of processing after each one.
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
-Re-save your permalinks settings at Dashboard > Settings > Permalinks > Click 'Save Changes'

Kind regards,
Dennis

January 24, 2019 at 8:34 am #3123948

talC-2

debug above

January 24, 2019 at 8:51 am #3124067

talC-2

the only section that is not translating the slag is: Properties (estate_property)

January 24, 2019 at 9:02 am #3124084

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

January 24, 2019 at 9:14 am #3124157

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

You credentials were posted publicly so I have to delete it. Could you please change your password and try to send them to me again? I will now re-enable access information box for you and set your next reply as private. Sorry for the inconvenience.

Kind regards,
Dennis

January 24, 2019 at 9:39 am #3124339

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Weird. For some reason, your message are still posted publicly. Can you please send it again and check ' Make my reply private.'?

Kind regards,
Dennis

January 24, 2019 at 10:12 am #3124495

talC-2

I dont have the option to send private

January 24, 2019 at 10:25 am #3124530

talC-2

U changed the original slag to Swedish : egendom

January 24, 2019 at 10:49 am #3124608

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

It seems that your settings in WP Residence theme options > Edit Property, Agent, Agency and Developer text links are affecting the permalinks. If possible, could you please try to remove those custom url/permalink settings for WP residence? If that's possible, please also clear the cache.

Thank you.

Kind regards,
Dennis

January 24, 2019 at 10:56 am #3124616

talC-2

We need them

I just need to translate them without causing 404

January 24, 2019 at 11:00 am #3124628

talC-2

catch cleaned