This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 6 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 15, 2018 at 12:10 pm #2138374

jeffryD

Any word on a speed update?
I moved a staging site to a host where I could give it 2GB of ram and 3vcpu cores.
practically nothing is being used but it's still unworkably slow.

Both on the back end and the front end.

until I turn off wpml...

May 16, 2018 at 5:56 pm #2162221

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Could you provide information regarding the speed of the site with and without WPML?

Kind regards,
Carlos

May 17, 2018 at 3:29 pm #2178840

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I applied some minor changes that should improve the performance in the backend for WPML. however there isn't a big change.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Best regards,
Carlos

May 17, 2018 at 10:02 pm #2183754

jeffryD

I did as you suggested, changed theme to 2017 and disabled all plugins excluding those needed for woo wpml, nothing major performance wise happened.

Something screwed up the backup I make with wpclone, so I had to start over with a fresh clone from the main site and for some reason it is +- a second faster when loading products in the back end.
Maybe the new version of wordpress has something to do with it.

Thank you for your input, I hope further updates improve the speed further.

May 17, 2018 at 10:17 pm #2184037

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I'm sorry to hear that you had to start over. I asked my colleagues and they confirmed that the new version of WPML will have improvements in the performance.

I recommend you to update the plugin as soon as the new version is release and compare the performance before and after.

Please don't hesitate to contact us if you need our help in the future, we will be more than happy to help.
Best regards,
Carlos